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INSTALLATION

1. QUICK method: 2. HANDY method:

Extract script from archive to any folder. Extract script into folder:

In After Effects go to “File>Scripts>Run Script File...” “After Effects Path/Support Files/Scripts/Script Ul Panels” on Windows OS

Select script from the files. “‘After Effects Path/Scripts/Script Ul Panels” on MAC OS

(this method allows to use script as floating panel) In After Effects run script from “Window” menu. It will allow to dock the panel anywhere.

NOTE

Also make sure you have allowed scripts to write files under After Effects preferences:
MacOS: After Effects>Preferences>General>Allow Scripts to Write Files and Access Network
Windows: Edit>Preferences>General>Allow Scripts to Write Files and Access Network

Synchronize Time of All Related Ttems
Expression Pick Whip Writes Compact English
Create Split Layers Above Criginal Layer

} Allow Scripts to Write Files and Access Nebwark
Enable JavaScript Debugager
[[] Use System Color Picker

D Dynamic Link with After Effects Uses Project File Name with Highest Number




HOW TO WORK WITH ANIMATED TYPEFACE

n Import your typeface into After Effects Open FontManager script, 3 Type your text in this field
and make sure that folder’'s comment Click “Refresh” button and click “Write text” button.
section starts from “Typeface” word. and select your font.
=
MName Type Comment Wiite text
~ Il Typeface Multis Folder Typeface Multis m
» Il Font Solids Folder TI'-"_PE Make Settings
> M Numbers Folder
> Wl Punctuation Folder ' .
> I Uppercase Folder
> Il Written Folder
= #Kerning_data Composition
Al Multis Metrics Composition '@  FontManager |

Type Make Seftings

: i Multis ~ o _
Multis
'lT A px




E Make

i Multis
1T 150 px Ii
E 1] i
e » =

Create text

auto ! px

¥

TEXT OPTIONS

—

© © N O o A~ W N

. Choose font alignment

. If necessary, you can change the layers order =i \WWD2D / &1 WCRD

. Type your text here  #elio

. Or, if you want to type multiline text use this button

. After adding animated font click “Refresh” ¢ and select font  mums v
. Setup font size T 200 ex | |eading = =« ex gnd tracking & © =
. To make layers appear sequentially, choose layers offset & o

. Activate ¢ , if you want to control all parented properties using one layer

If you need to turn on “Collapse Transformation”, activate icon =

IiF

10. Click Create text to write text

You can use these options 1 * & ¢ & = even after you have written the text.
Just select “Controller ” layer and click on any of these icons.
If you want to shift your layers in time, click &

You can set “auto” mode = = ex by clicking on = icon
You can reset font size to “150” px ' 200 ex | by clicking on T icon




Type Make Settings

QUICK START
Create typeface
A-z | Customize character set
£n Create template

:I | Create character [ayers

ﬁ Move layers to comps

</> | Mark Controller expressions

Kerning and metrics

\F‘E Add kerning and metrics

+ Add quick metrics

Other

A | Add guide characters || Wi

& Parent properties o

% _ Copy/Paste property

Demo all glyphs

“As | 4 A b

QUICK START

Guide, that helps quickly
create animated typeface.
Just follow the steps and
select needed options.

WORKING WITH FONT
* Create new Alphabet

Manage existing Alphabet

Mext

&  Parent properties

Select properties, for example
colors, that you want to manage
further. Then click

“‘Parent properties” button.

:I Create character layers

All your properties would be parented

to “Controller” layer.

© Color  HE —-
© [Color | H —-
© [Coler | I -

Shift+Click will parent these properties

inside each composition

of the animated font. Just make sure

that all these properties
have the same path.

Create new text layer

and click this button.

Script will create all

chars, symbols, humbers

using shape layers.

(or Shift+Click to use solid layers)
& ScurceName B3¢

Sa.
2

=l 1 * A
»ll 2 =*»&B
»l 3 =»cC

+

“‘Advanced Parenting” button
allows to automate parenting
process inside all font

compositions and even more.

Just type layer index and
property name or setup
other parametrs.

There are bunch of useful
options. You can find out
more, by watching video
tutorial.

CREATE ANIMATED TYPEFACE

3] Move layers to comps

Select layers and click button.
Script will group layers into
individual comps and sort
them into folders.

1 * A
Bl 2 =»B

v BB Alphabet Helvetica
v im Uppercase

= A
e

Demo all glyphs

Create demo of all animated
chars, nums and symbols,
to make sure that there is no

errors or to create presentation.

Click “Demo All Glyphs®,
and “Write Multiline”.

Aa Bb Cc Dd Ee Ff Gg
Hh li Jj Kk LI Mm Nn
Oo Pp Qq Rr Ss Tt Uu Vv
Ww Xx Yy Zz
0123456789

E?’ﬁ Add Kerning and Metrics

This is a key feature of the script, that has no analogues.
It takes into account the shape of the letters
and creates the correct metrics.

« Add Kerning and Metrics 3§ Automatic Metrics

oooooooo

perfect \ \ too far
too close

1. Convert your font into .afm file
here: https://goo.gl/EfEaPi  ( .ttf )
or here: https://goo.gl/NX6Smf  ( .otf)

2. Create composition using the same size as
comps of your animated font.

3. Create text layer using the same font and size
as your characters from animated font.

& SourceName o 3F

4. Select text layer.
5. Click “Add Kerning and Metrics”.

B Multi

Multis.otf

6. In the opened window select your font (.ttf or .oftf) file
of font’s .afm file and click “OK".




Font Manager

Type Make Settings

QUICK 5TART

Create typeface

A-z Customize character set
£ Create template

:I Create character layers
=l Move layers to comps

</> | Mark Controller expressions

Kerning and metrics

"-ﬁ'«.;_ Add kemning and metrics

tt Add quick metrics

Other

A | Add guide characters || Wi

& Parent properties +
% Copy/Paste property
Demo all glyphs

ife | 4 A [ ]

CREATE ANIMATED TYPEFACE

hm § Add quick metrics |

Add quick metric based

on a glyps’s width.

This method is suitable only
for monospaced fonts.

i__ If you will use this
I metrics for non
1
1
1
1
]

monospaced font,
- _some characters
may not fit properly.

e —

1. Create composition
with the same size as
your characters comps

2. Create text layer
using the same font and
size as your characters

& ScurceMame B 3F

0 T -

3. Select text layer

4. Click “Add Quick Metrics”

A-z Customize char set

Here you can manage/add set

of the characters that would be used
during the creation of the

alphabet template and layers.

A
a-z
0-9
Sy
Add = LTB§¥
Close
af A A k

Navigation buttons help quickly
switch between the glyphs
composition.

Click on the central button
will open the composition
with the glyph.

For current example, script
will open “A” composition.

Create template |

Quickly creates typeface structure.

1. Create composition that would
fit character and its animation.

2. Create text layer with one letter
and setup your font and its size.

3. Select text layer and click

"New Alphabet template”,

to generate font structure using

shape layers.

(Shift+Click will do the same, but using

/> | Mark Controller expressions

solid layers)

¥ I Alphabet Helvetica
» M Lowercase
» Il Numbers
» Il Punctuation
vrim Uppercase

Helps to mark controller layer inside presomps
and across the project after using “Parent properties”.
function. Use it for complex typefaces.

1. Select the typeface folder under the Project panel

2. Click on “Mark Controller expressions”

Expressions will be switched from this:

eryl thisComp. layer{"Centraller®.effect(MHuleis™) ("Cotar™) Jeateh(e)( valus ]

To this:

ey
war Fi coatrollerCoss = thisComn:

var Fe_contrallerlayer = FE_controllarCong. Laver (“Contraller! )

tryl FM_controllerlayer.effect|"muleis™) ("Color™)

Featchiel{ waloe }

jeatchie)l valuve )




Font Manager

Type Make Settings

Install animated typeface

Font library: | B | _s/FMTypefaces

[:] Lise stylistic alternates

[:] Uise terminal characters
ﬂ Create new layers at CTI
B3 Add individual controls

ﬁ.ﬂ-ﬂ'd typesetting controls

[:I Precompose type
DM(F In/Cut via Time Remap

Open tutornials
Open Support ticket

Manage license and updates

Textmod None il B

Registered to: ALEX WHITE

Created by: Alex White

Install animated typeface |

This will install JSX typeface
in to your system (by default under

so you wouldn’t need to import AEP

file into project every time

you want to use the typeface.
1. Click on “Install animated typeface”

2. Open the folder with the typeface
and select file with “.jsxbin”

extension there.

Font library: | I | _s/FMTypefaces

Here you can change installation
folder for the typefaces.

Click on the name at the right
to reveal the installation folder.

Date hMadidiod

12 K8 16 Septomber 2017, 13220

Canca] - RN I-

3. The typeface will be installed automatically.
You can no open “Type” tab and write text there.



Type Make Settings

Install animated typeface |

Font library: | -! -.5/FMTypefaces

D Lise stylistic alternates

[] Use terminal characters
Create new layers at CTI
Add individual controls

Add typesetting controls
D Precompaose type

[C] Add In/Out via Time Remap

Open tutorials |

Open Support ticket |

Manage license and updates |

|
Textmod None L I¢,|

Registered to; ALEX WHITE
Created by: Alex White

SETTINGS

] Use stylistic alternates [[] Use terminal characters

Terminal characters are stylistic

alternates that go at the end of
Randofn versiors a word. Most commonly used
in script or handwriting fonts.
Only available in certain
animated typefaces.

You can enable this feature
if your typeface supports
stylystic alternates and glyphs
have different design and animation. ~ Il Madita
> o1 Uppercase
» Il 02 Uppercase Accents
> M 03 Lowercase
> 1M 04 Lowercase Accents

e |05 Lowercase Terminal Forms

~ Il Mobile Animated
Y #Kerning_data
> Il 01 Uppercase
» o2 Uppercase Accents

> HH 03 Lowercase B=E a_ terminal

~ Il 04 Lowercase Accents X b_terminal
4.1 ¢_terminal
R a 2 B d_terminal
wid 3 i

R a 1

To add support of stylistic
alternates, add underline and number
to your comp’s name.

For example “F_1" or “F_2”
and so on.

Create new layers at CTI

Will create characters at the
current time indicator.

When disabled, all layers will

be placed at the start of compsition.

Add typeselting controls
D Frecompose type

] Add InfOQut via Time Remap

Add individual controls

Add a controller to each glyph
to toggle between overal and
individual settings

+ fx Madita Controller Reset
Animation Presets: None v 4 b
) Main Color D E
) Accent Color =
» ) Stroke Thickness 50,0
> ) Wedge Width 15,0
~ ) Wedge Angle 0x+20,0°*
» ) Ink Blend 0,0
y ) Out Animation (f) 100
) Bulge and Splashes Checkbox
~ fx Use own settings Reset
Animation Presets: None Lt i
) Checkbox M|




SETTINGS

(@ FontManager
T}rp:E Make Settings Add typesetting controls |:| Precompose type |:| Add In/Out via Time Remap
Install animated :
| Nss animbted typelace | Add a Eont Controller to Controller Precompose all glyphs layers Add In and Out keyframes on Time Remap
layer with tracking, spacing after the text is created. based on workarea of glyphs’s comp.

Font library: | I | ..s/FMTypefaces

and offset parameters. ] .
3 (LR Socm e e This option automatically creates Out animation

Use stylistic alternates I8 Pre: ' s
L] Ssestypticaltent ST el z : : ; ::f:?::ﬂ:;?“'l based on the workarea inside of each glyph.
 Constant versian 1 } ﬁTmf_kjﬂg D,ﬂ-l.'.!
() Constcutivie versions » [ Tracking center 0,00 B A x W Il5‘53“"'“3"1 ==
O fandom b ions > © Line spacing 8,12 i -elick for alternate display style eSS
_ ) Eandom versions . .E‘I'rﬂﬁﬁtt 0,00 “-uuﬂggu?; P -T: *E & |! @ . .
[[] Use terminal characters s 05 Z-Offset 0.00 i
’ oddbend W « Source Name
B4 Create new layers at CTI = s B 1 % i A[Controller]
£4 Add individual controls If unchecked, no expressions will ‘i’ vl 2 A
4 Add typesetting controls be applied to the position property. *:¥ © & Time Remap
D Precompaose type
Add In/Out via Time R . :
£} 49d inlOut V7lme fetmag To support it in your typefaces, make sure workarea duration
matches In animation duration.
Open tutorials
Open Support ticket
Manage license and updates M{Enﬂg&?pin} ® IE O El a0 n{j 02s 03s D';!. L'Hiis
ol oo W ¢ | Lyerneme [ ,
Textmod Mone i |: O y . 1 En Lﬁ‘h“_ﬂﬂ S T
> 2 B Controller
Registered to: ALEX WHITE o >l 3 Y Seconda..ents
Created by: Alex White >l 4 % [3] AAlpha
o > 5 % E] Lines
> I 6 % [=] AMatte
@ » B 7 % E] AShape




QUESTIONS AND ANSWERS

n SCRIPT CAN'T SEE MY TYPEFACE

Make sure that your folders named properly,

and main folder has a comment, that starts from “Typeface .

.ﬂ Mama Type Comument

® v W muhis Folder A| Typeface Multis
[ » Il | owercase Folder

i » Il Numbers Folder

s » Il Punctuation Folder

111 » Il Uppercase Folder

i) Y Multis Metrics Composi...

E WRONG LINE SPACING

Setup these layers under “Metrics” composition

of your font animated.

Layer Name B3 I
* 1 A il |
# Settings 2 /6
* Grid ENEA |

% Caps L SE=2vd
# Baseline Ay ogE

E CAN SCRIPT WORK WITHOUT METRICS?

Nope, metrics is required for setting up
the proper spacing between the characters.

ﬂ WRONG SPACING BETWEEN THE CHARACTERS

Make sure that you have setup Metrics correctly and

your characters are centered. You can also try to move your

character inside composition.

E PROBLEMS WITH PARENTING PROPERTIES

Make sure that the effects have the same order inside

each “Controller” layer inside all font compositions.

ALY BLY
» 35 Slider 100,00 > & Slider 100,00
fc Color Reset fc Color Reset

© Color = © Color =
fr Color 2 Reset i Color 2 Reset

B Color == B Color ==

B ==
Reset
N =
Resel
100,00

| WANT TO ADD SYMBOLS
THAT ARE MISSING IN THE STANDART SET

Go to “Setup” tab and click “Customize Char Set”

and under the “Add” field add your characters and symbols.

A=

a-9

Sy

Add  ETERY




QUESTIONS AND ANSWERS

WHY DO | NEED KERNING AND METRICS E WHY DO | NEED AN .AFM FILE?

This system provides correct spacing between .afm - Adobe Font Metrics, it contains font metrics and kerning values

the characters taking into accout shape of the characters

and makes visually pleasing result. E PARENT PROPERTIES FUNCTION

Correct metrics is an essential part of any DIDN'T PARENT ALL MY COLORS

work with the text. If there are several colors that have the same value,

they would be parented to the same controller.

You can see the difference between the quick metrics . ) .
. It would save lots of time during setting up the colors.

and correct metrics on the AV example.

Some characters have to have more spacing,

some less. E WHY DO | NEED “CREATE ALPHABET LAYERS” BUTTON,
IF | CAN USE “ALPHABET TEMPLATE"

“Create alphabet layers” allows quickly copy/paste animation through all
layers and then place them into individual compositions so you

don’t need to navigate through each composition.

All in one place. Very handly.

correct - taking into accouit shape of the; letter there should be an offset m DO YOU PLAN TO RELEASE UPDATES?
We are constantly working on new features.

: k | E | FOUND ABUG /| HAVE A FEATURE REQUEST /| NEED A SUPPORT
wrong - all the letters are perceiving as squares Drop me a line on support@motion.land




QUESTIONS AND ANSWERS

E HOW TO SETUP ARABIC AND HEBREW INPUT

Download Arabic or Hebrew text mod here:
http://aescripts.com/after-effects/text/text-modifier/

Install it with Font Manager under the Settings tab.
Select your text mod and restart Font Manager.

Now you are ready to write with Arabic or Hebrew characters.

Type Make Settings

Install animated typeface

Font library: -' ..5/FMTypefaces

[] Use stylistic alternates

[] Use terminal characters
Create new layers at CTI
Add individual controls
Add typesetting controls

[} Precompose type
[C] Add In/Out via Time Remap

Open tutorials
Open Support ticket

Manage license and updates

Text mod MNone e |

Registered to: ALEX WHITE
Created by: Alex White

"% TM_Hebrew Text | .

Text Mods: | T _Hebrew Text



