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installation

                      can be run as a dockable panel or as a window.

To install and run as a dockable panel (will be visible in the "Window" menu):

     Copy the file                                  into the folder:

    "..Support Files/Scripts/Script UI Panels" (on Windows)

    or "..Scripts/Script UI Panels" (on MacOS) of your After Effects installation.

     Restart After Effects

TTo install and run as a window (will be visible in the File -> Scripts Menu):

     Copy the file                               into the folder:

    "..Support Files/Scripts/" (on Windows)

    or "..Scripts/" (on OS X) of your After Effects installation.

     Restart After Effects

keyboardFX

1.           keyboardFX.jsxbin

2.

1.                             keyboardFX.jsxbin

2.

description

keyboardFX                     is a tool for Adobe After Effects, specifically designed to create
highly customizable keyboards together with user defined typing animations.
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Besides the custom text,
there are five presets
for generating interesting
lighting key animations:

_ sequentially horizontal
_ sequentially vertical
_ _ random
_ spiral-in
_ spiral-out

Starts the generation procedure

Here you can type the custom 
text that keyboardFX will

generate typing animations for.

Please refer to pages 5-8
on this guide for more
information on how to
illuminate special keys.

Clicking on the logo brings up
a window with small help tips.

Here we will also find a
list of special codes for

illuminating  the
modifier (CTRL, SHIFT etc.)

cucursor (arrow keys)
navigation (Page Up/Down etc.)

and numneric pad
keys of a keyboard

The script can be run as a dockable panel (will be visible and run from the 
“Window” menu of After Effects) or in “window mode” (visible and run 
from the File -> Scripts menu). The mode depends on which folder you in-
stall the script in (see instructions on page 2)
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Speed Slider Mode: In this mode, the typing speed of the generated 
text is controlled from the “Type Speed” effect control. This controls 
the speed of the typing animation as a whole.

Using Markers Mode: In this mode every character of the generated text is assigned to a named marker on 
the timeline. There is no “Type Speed” slider. You can presicely time your typing animation by moving each 
marker.
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select between a
QWERTY, AZERTY or DVORAK

keyboard layout

Enables the 3D switch for 
all layers that keyboardFX 
creates and applies a 
small extrusion to the 
keys and backplate of the 
keyboard

creates separate text 
layers for each key of the 
keyboard

enables the shy switch 
for all the key text layers

enables/disables the
progress bar

You can select between 7 basic 
types of keyboards.

Keep in mind that all keyboards are 
highly customizable with a lot of 

effect controls.

The 7 basic types of keyboards are:

Apple - Dark __
Apple LigApple Light __
PC - Dark __

PC Classic 2-Color Beige __
Mobile/Tablet Dark __
Mobile/Tablet Light __
Commodore 64 __
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special codes

A keyboard apart from the CHARACTER keys, also features a lot of extra keys.

These typically are:

The FUNCTION keys: F1, F2 . . . F12 etc.
The MODIFIER keys: ALT, CTRL, SHIFT, MENU etc.
The ARROW keys: 
The NAVIGATION keys: INSERT, DELETE, HOME, END, PAGE UP etc.
The The NUMERIC KEYPAD keys: 0....9, NUM LOCK, SLASH, ASTERISK, MINUS SIGN, ENTER etc.

In order for keyboardFX to understand -on a string 

of text- that you want these keys to be illuminated, 

a special code must be typed. This special code is 

nothing more than double curly brackets before and 

after the special key you want to be illuminated, like 

this: {{SPECIAL KEY}}

For example:

YYou want keyboardFX to generate typing animations 

for the following two words: Hello World! and im-
mediately after that, you want to illuminate the 

“Page Down” key. What you should write in the text 

field of keybardFX is: Hello World!{{PAGE DOWN}} 

and then press the “Generate keyboard!” button.

There are detailed lists of all special codes for each basic keyboard in the following pages.
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special codes - Apple

Escape:

F1:

F2:

F3:

F4:

F5:

F6:F6:

F7:

F8:

F9:

F10:

F11:

F12:

::

{{ESC}}

{{F1}}

{{F2}}

{{F3}}

{{F4}}

{{F5}}

{{F6}}{{F6}}

{{F7}}

{{F8}}

{{F9}}

{{F10}}

{{F11}}

{{F12}}

{{{{EJECT}}

F13:

F14:

F15:

F16:

F17:

F18:

F19:F19:

{{F13}}

{{F14}}

{{F15}}

{{F16}}

{{F17}}

{{F18}}

{{F19}}{{F19}}

fn:

home:

page Up:

delete:

end:

page down:

{{FUNCTION}}

{{HOME}}

{{PAGE UP}}

{{NAV DELETE}}

{{END}}

{{PAGE DOWN}}

arrow up:

arrow left:

arrow down:

arrow right:

{{ARROW UP}}

{{ARROW LEFT}}

{{ARROW DOWN}}

{{ARROW RIGHT}}

clear:

= :

/ :

* :

7 :

8 :

99 :

- :

4 :

5 :

6 :

+ :

1 :

22 :

3 :

0 :

 . :
enter:

delete:

tab:

caps lock:

return:

left shift:

right shift:

lleft control:

left option:

left command:

spacebar:

right command:

right option:

right control:

{{DELETE}}

{{TAB}}

{{CAPS LOCK}}

{{RETURN}}

{{LEFT SHIFT}}

{{RIGHT SHIFT}}

{{LE{{LEFT CONTROL}}

{{LEFT OPTION}}

{{LEFT COMMAND}}

{{SPACEBAR}} (optional)

{{RIGHT ACOMMAND}}

{{RIGHT OPTION}}

{{RIGHT CONTROL}}

{{NUM CLEAR}}

{{NUM EQUAL}}

{{NUM SLASH}}

{{NUM ASTERISK}}

{{NUM 7}}

{{NUM 8}}

{{NUM 9}}{{NUM 9}}

{{NUM MINUS}}

{{NUM 4}}

{{NUM 5}}

{{NUM 6}}

{{NUM PLUS}}

{{NUM 1}}

{{NUM 2}}{{NUM 2}}

{{NUM 3}}

{{NUM 0}}

{{NUM FULL STOP}}

{{NUM ENTER}}
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special codes - PC

Escape:

F1:

F2:

F3:

F4:

F5:

F6:F6:

F7:

F8:

F9:

F10:

F11:

F12:

{{ESC}}

{{F1}}

{{F2}}

{{F3}}

{{F4}}

{{F5}}

{{F6}}{{F6}}

{{F7}}

{{F8}}

{{F9}}

{{F10}}

{{F11}}

{{F12}}

Print Screen:

Scroll Lock:

Pause/Break:

{{PRINT SCREEN}}

{{SCROLL LOCK}}

{{PAUSE BREAK}}

Insert:

Home:

Page Up:

Delete:

End:

Page Down:

{{INSERT}}

{{HOME}}

{{PAGE UP}}

{{NAV DELETE}}

{{END}}

{{PAGE DOWN}}

Arrow Up:

Arrow Left:

Arrow Down:

Arrow Right:

{{ARROW UP}}

{{ARROW LEFT}}

{{ARROW DOWN}}

{{ARROW RIGHT}}

Numbers Lock:

Slash:

Asterisk:

Minus Sign/Dash:

Seven:

Eight:

Nine:Nine:

Plus Sign:

Four:

Five:

Six:

One:

Two:

ThThree:

Zero:

Full Stop:

Enter:

Backspace:

Tab:

Caps Lock:

Enter:

Left Shift:

Right Shift:

LLeft Control:

Left Windows:

Left Alt:

Spacebar:

Right Alt:

Right Windows:

Menu:

RigRight Control:

{{BACKSPACE}}

{{TAB}}

{{CAPS LOCK}}

{{ENTER}}

{{LEFT SHIFT}}

{{RIGHT SHIFT}}

{{LE{{LEFT CONTROL}}

{{LEFT WINDOWS}}

{{LEFT ALT}}

{{SPACEBAR}} (optional)

{{RIGHT ALT}}

{{RIGHT WINDOWS}}

{{MENU}}

{{RIGHT {{RIGHT CONTROL}}

{{NUM LOCK}}

{{NUM SLASH}}

{{NUM ASTERISK}}

{{NUM MINUS}}

{{NUM 7}}

{{NUM 8}}

{{NUM 9}}{{NUM 9}}

{{NUM PLUS}}

{{NUM 4}}

{{NUM 5}}

{{NUM 6}}

{{NUM 1}}

{{NUM 2}}

{{NUM 3}}{{NUM 3}}

{{NUM 0}}

{{NUM FULL STOP}}

{{NUM ENTER}}
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special codes - mobile/tablet

special codes - Commodore64

F1:

F3:

F5:

F7:

{{F1}}

{{F3}}

{{F5}}

{{F7}}

{{RESTORE}}

{{RETURN}}

{{LEFT SHIFT}}

{{CURSOR UP DOWN}}

{{CURSOR LEFT RIGHT}}

Restore:

Return:

Left Swift:

Cursor Up/Down:

Cursor Left/Right:

{{CONTROL}}

{{COMMODORE}}

{{RIGHT SWIFT}}

Control:

Commodore:

Right Shift:

{{CLEAR HOME}}

{{INST DEL}}

Clear/Home:

Instert/Delete:

Return:{{RETURN}}
{{LANGUAGE}}Language:

{{SYMBOLS}}Symbols:

Shift:{{SHIFT}}

Backspace:{{BACKSPACE}}
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pause/hold

Apart from special codes for each keyboard there are also two extra codes that apply to every keyboard 

that keyboardFX generates.

PAUSE

The {{PAUSE}} code. This code pauses the animation of the keys for a brief moment. The duration of a 

single PAUSE is one keystroke. You can prolong the duration of a PAUSE for more than one keystroke by 

putting a number after the HOLD code. You can enter {{PAUSE1}}. . . up to {{PAUSE30}}.

For example if you enter the following text in keyboardFX text field:

This This takes a long {{PAUSE10}} time!

The typing of the text will begin, then just after typing the word “long”, it will pause for a few moments 

and then continue typing the rest of the given text.

HOLD

The {{HOLD}} code. This code prolongs the duration of the illumination of a key by one keystroke.

For example if you enter the following text in the keyboardFX text field:

LLet’s see a key combination!{{LEFT CONTROL}}{{HOLD3}}{{RIGHT ALT}}{{HOLD2}}{{NAV 

DELETE}}{{HOLD1}}

The typing of the text will begin. The Left Control key is going to illuminate, then while it stays illuminat-

ed the Right Alt key is going to light up, and while both of these keys stay illuminated the Nav Delete 

key is also going to light up. When all three light up completely, then they all going to turn off simultane-

ously.

The duration of a single HOLD is one keystroke. You can prolong the illumination of a key for more than 

one keystroke by putting a number after the HOLD code. So you can enter {{HOLD1}}...up to {{HOLD30}}

You can use the {{HOLD}} command to show key combinations, even light up complete rows or sections 

of a keyboard.

NOTE: The HOLD command works only in the “Speed Slider” mode.
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effect controls

effect controls for adjusting 
the look of the backplate

effect controls for adjusting 
the color, size, position, track-
ing and line spacing of the text 

layers for each key

effect control for adjusting
the cursor blinking rate

effect controls for adjusting
the roundness size, spacing, color 
and glow properties of the keys

effect controls for adjusting
the typing speed and the 

pre-run time

Once the keyboard has been generated, you will find a number of the following 

effect controls in the effect panel of the shape layer of keyboardFX.
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You can test keyboardFX free for 7 days. In trial mode these limitations 
apply:

- 15% of the total keys of the keyboard will not be available

trial limitations

keyboardFX is compatible and has been successfully tested on:

- After Effects CS6
- After Effects CC
- After Effects CC 2014
- After Effects CC 2015
- After Effects CC 2015.3
- - After Effects CC 2017
- After Effects CC 2018
- After Effects CC 2019
- After Effects CC 2020

on both Windows and Mac OS platforms.

compatibility
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1.2    November 28th, 2019

   - fixed: a bug which prevented the complete generation of Commodore64 keyboards on AE CS6

   - fixed: the random preset for Commodore64 was not random. It now fixed.

   - fixed: a few typing errors on some of the presets

   - fixed: a bug where the custom input text field was locked on first run on AE CS6

   - fixed: carriage returns no longer mess the timing of the animations and properly light up the "Enter" key

      - fixed: the order of the layers became shuffled, if there were other existing layers in the timeline. It's now fixed.

   - fixed: some layer properties stayed open in the timeline after the generation of the keyboard.

          It's now fixed and every property is closed (twirled up)

   - changed: the glow and key layers are no longer locked

   - changed: renamed the effect control "Glow Decay" to "Glow Decay Speed" for better clarity

   - changed: smaller UI + a few cosmetic changes

      - optimized: before generating any keyboard, keyboardFX checks the input text and informs the user                 

            about mistyped special codes

   - optimized: when deleting keyboardFX layers, expression errors are now suppressed 

   - optimized: the -initial- typing speed and glow decay speed is automatically adjusted at a comfortable                

             pace of approximately 8 characters per second

      - optimized: redesigned progress bar that is more accurate, more informative, and works both in window              

             and in dockable panel mode. Also added a enable/disable checkbox for it, in the settings tab (CS6  only)

      - optimized: compatibility with macOS Catalina

   - optimized: instead of typing multiple {{PAUSE}} codes to further prolong a pause you can now type                  

             {{PAUSE1}} through {{PAUSE30}} (the same applies with the HOLD code)

   - added: the {{HOLD}} special code which allows the illumination of key combinations (like Ctrl+Alt+Del)

   - added: a second mode of controlling the keystroke animations through markers (Using Markers Mode)

1.1    January 9th, 2019

   - added: the DVORAK keyboard layout

      - added: five keys lighting animation presets

   - optimized: broadened compatibility. keyboardFX in now compatible with older versions of After Effects (CC + CS6)

   - changed: keyboardFX no longer uses the "Arial" font as the default font for every text layer it generates.

           It will now use what ever font is selected in theAfter Effects Character Panel upon generation.

1.0    October 28th, 2018

    - initial release

version history



copyright 2019 @ Real Creations

www.realcreations.gr

This script is provided "as is," without warranty of any kind, expressed or implied. 
In no event shall the author be held liable for any damages arising in any way from 
the use of keyboardFX.


