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2 Overview 
 

Beepee Dynamic Line Chart (DLC) is a plugin for Adobe After Effects that instantly creates charts 

from data. All the parameters of the chart and the data itself can be animated.  

Data for your chart can be imported via a CSV file from spreadsheet applications such as Microsoft 

Excel or Google Drive. Or you can resample data from an image of a chart. 

By animating display parameters, you can zoom into and out of the chart, along axes, highlight 

regions and add decorations to help explain your data to your audience.  

Dynamic Line Chart can help you save hours or even days working on both simple and complicated 

charts.  

DLC has hundreds of parameters and many functions to produce charts. It is therefore quite a 

complex plugin. This guide is intended to accompany the video tutorials available at aescripts.com, 

and on the Beepee Youtube channel. Further help can be found at the aescripts.com support forum. 

 

3 Installation 
 

DLC can be installed automatically using the aescripts + aeplugins manager app.  

Manual installation is also possible.  

• Download the zip file from aescripts.com and open it.  

• Close any instance of After effects. 

Windows. 

• Place the downloaded DynamicLineChart.exe file in C:\Program 

Files\Adobe\Common\Plug-ins\7.0\MediaCore (or equivalent path).  

Mac 

• Place the downloaded DynamicLineChart.plugin file in /Applications/Adobe After Effects 

2020/Plug-ins/Effects (or equivalent path).  

DLC can then be found in Effect → Beepee → Dynamic Line Chart. 

 

 

 

  

https://aescripts.com/learn/aescripts-aeplugins-manager-app/
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4 Limitations & known issues 
 

Currently, only one instance of DLC can be applied to a layer object (usually a Solid) at a time. DLC 

will draw only the lowest active (displayed) instance of DLC on the effect stack. However, many DLC 

instances can be applied each to different layer objects in the same composition at the same time, 

allowing complex, layered animations.  

Each instance of DLC can draw up to 32 objects. If you require more than 32 objects in a 

composition, objects can be split between two instances of DLC, with chart features such as grid 

lines and axis labels disabled on the topmost layer. This limitation is somewhat arbitrary, intended to 

optimise performance. If you really need more than 32 objects and this solution does not work for 

you, please get in touch through aescripts.com. 

DLCs capacity for imported data through CSV files has not been tested to destruction and no cap has 

been put on the size. However, if you are importing many MB of data, you should take care to back 

up your work beforehand. 

Currently DLC is not able to draw text labels on the vertical axes. It is also not yet able to draw non-

linear or log axes. 
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5 The interface 
 

 

 

DLC has hundreds of parameters. They are organised into topics to make it easier to use. 

Each topic contains the parameters particular to one aspect of your chart.  

 

Screen area – the height and width of the main drawing area of your chart, not including 

axis labels and titles.  

Grid & axes – these parameters control the dimensions and display of axis, gridlines and axis 

labels.  

Titles – you can add a main chart title, and titles for the horizontal and primary and 

secondary axes.  

Legend – these parameters let you set up a legend to explain the content of your chart.  

Data – import or copy data here. 

Objects – An ‘object’ refers to a drawing that shows your data, a bit like AE’s Shape layer. 

For example the line on a line chart, or the markers at each data point in a series of data are 

‘objects’ in DLC. DLC has a number of different drawing types. Each new instance of an 

object creates a new object topic.  

 

Each of these topics and their sub-topics are explained below.  
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5.1 Screen area 
 

 

 

Screen area parameters let you define the chart area’s dimensions and style. The 

dimensions – Top right and Bottom left – describe the drawing area of the chart. Other chart 

elements such as axis labels and titles are drawn outside of this area.  

 

The background is a single colour, drawn behind the chart area. You can also add a border, 

which can be drawn beneath or on top of other chart features.  

 

5.2 Grid & axes 
 

DLC gives you a great deal of control over the grid and axes, their dimensions and 

properties. 

 

 

At the top of the Grid & axes topic, you can choose whether to show each axis’s labels. 

 

The parameters are then divided into topics for each axis.  
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5.2.1 X-axis, Y-axis & Y2-axis 

 

Most of the parameters and topics for each axis are similar. But some of the parameters 

available for the X-axis are not available for the primary and secondary vertical axes. And 

the secondary vertical axis has fewer parameters. For example, DLC will not draw grid lines 

for the secondary vertical axis, but it can draw ticks on the secondary axis.  

 

5.2.1.1 X-axis / Y-axis / Y2-axis dimensions 

 

You can set the ranges of each axis using the Min and Max parameters. In this way, you can move 

the chart along an axis, or scale it to produce a ‘zoom’ in or out.  

The Step parameter allows you to tell DLC how far apart you want the main gridlines to be. You can 

then specify how many subdivisions between the main grid lines using the Subdivisions parameter.  

The functioning of the Step and Subdivisions parameters changes if you change the ‘Axis depth’ 

parameter in the Axis display settings, explained in the next section.  

The Min-max offset parameter allows you to offset the range between Min and Max. This is useful if 

you want to move along an axis, while keeping the Min and Max parameters free for scaling the axis. 

The Shift label/gridline parameter lets you change the points on the axis at which axis labels and grid 

lines appear. For example, suppose your horizontal axis had Min and max values of 0 and 100, and a 

step size of 10. This would show grid lines every ten units, from 0 to 100. If you now set the Shift 

label/gridline parameter to 1, the axis will still show the range 0 to 100, but the first gridline and 

label will appear at 1 rather than 0, the second will appear at 11 rather than 10, and so on. 
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These parameters are the same for all three axes. 

 

5.2.1.2 X-axis / Y-axis / Y2-axis display 

 

The axis display topic contains main parameters that control the display of the axis.  

For the x-axis, placement allows you to place the x axis labels at the top of the chart, bottom or 

both.  

For all axes, the location dropdown allows you to place the axis labels on the inside or outside of the 

chart.  
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There are also options to draw gridlines, ticks and sub ticks. These have more parameters in their 

own topics below.  

Dashes can be enabled with the Dashes checkbox. The Dash on, Dash off and offset parameters are 

all in pixel space.  

Axis depth allows you to change the way the axis labels and grid lines are calculated. The choices are 

‘static’ and ‘dynamic’. 

In static mode (default), the grid lines and grid labels are set exactly according to the parameters set 

in the axis dimensions topic. For instance if you have Min and Max set to 0 and 1000, with a step of 

100, and Subdivisions set to 10, DLC will draw 10 grid lines, with ten subdivision gridlines between 

each two major grid lines.  

Please see the How to… section, 10.7 Add dynamic grid depth for more detailed information on how 

to use a dynamic axis depth.  

5.2.1.3 Origin (X/Y) 

 

The origin topic lets you set a unique colour for the grid line that crosses zero on the axis.  

 

The parameters are self-explanatory. The Dash parameters values are in pixel space.  

5.2.1.4 Main lines (X/Y) 

 

These parameters let you set the properties of the main grid lines.  

 

  



Beepee DYNAMIC LINE CHART v1.0 

 

11 
 

5.2.1.5 Subdivisions (X/Y) 

 

The subdivision topic parameters set the drawing properties and behaviour of grid lines.  

Sub width, Sub color and Sub opacity are self-explanatory.  

 

The other parameters only have an effect in Dynamic grid depth mode.  

Maj distance determines the minimum pixel distance between major grid lines.  

Sub distance determines the minimum distance between two subdivision grid lines that there needs 

to be before they are drawn.  

Sub fade in sets the distance over which a subdivision transitions from invisible to visible in response 

to changing axis parameters (such as zooming).  

Sub-maj fade mix in sets the distance over a which a subdivision grid line transitions into a main 

gridline, for instance as the axis is being zoomed into.  

For more information about how to use these parameters, see the section 10.7 Add dynamic grid 

depth. 

 

5.2.1.6 Main ticks (X/Y/Y2) 

 

The Main ticks appear at the same points on the axis as the main grid lines.  

The parameters are self-explanatory.  

 

 



Beepee DYNAMIC LINE CHART v1.0 

 

12 
 

5.2.1.7 Sub ticks (X/Y/Y2) 

 

Sub ticks appear at the same points on the axis as the main grid lines.  

The parameters are self-explanatory.  

 

5.2.1.7.1 X-axis / Y-axis / Y2-axis labels 

 

Axis labels are the numbers (or text) that appear on the axis.  

 

Offset sets the distance from the axis to the labels.  

You can choose which character you want for Digit grouping and the decimal point.  

Axis fade width sets the distance over which axis labels fade out as they exceed the limits of the axis 

in pixels. This allows a smoother animation, for instance if you are moving your chart along the axis.  

The Axis fade offset moves the region over which the label is faded towards the centre of the axis, 

negative numbers move it away from the centre.  

The Axis Label’s Font and Background topics are explained below. 

See the How-to sections for more information on how to use labels in dynamic and static modes. 

5.2.1.7.1.1 Font 

 

The Axis label font parameters are self-explanatory.  
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5.2.1.7.1.2 Background 

 

The parameters in this topic let you draw a box behind the text. You can also draw a border around 

the box.  

Most of the parameters are self-explanatory.  

The Include descender parameter refers to the parts of the letters j,p,q,y ( ‘descenders’) which 

typically appear below the rest of a typeface. You might want to set this to ‘Never’ if you are working 

only with number or capital letters. Not all fonts contain information about the descender, so 

sometimes this parameter may not work as intended.  
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6 Titles 
 

If you require a title for your chart or any of the axes, you can set these up in this group of 

parameter topics.  

 

DLC’s titles offer a lot less functionality than After Effects text layers, but they are a quick way of 

adding text.  

The topic gives you the option of showing each of the titles.  

There is also a button to edit the titles, which opens a dialog. Just enter the title text, and click ‘ok’. 

 

NB: It is not possible to undo changes to the titles.  
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6.1 Chart / Horizontal axis / Vertical axis / Vertical2 axis title 
 

The offset parameter in this topic moves the title away from its axis.  

 

The Font parameters are the same as in section Font 5.2.1.7.1.1. 

The Background parameters are the same as in section Background 5.2.1.7.1.2. 
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7 Legend 
 

Legends help you add clarity to a chart. If you enable the Draw legend check box, DLC will draw a 

legend if objects are assigned to legend ‘slots’.  

 

The Legend anchor and Legend placement parameters let you decide where to draw the legend. The 

legend will place the part of the legend (eg: top left, centre, bottom right) selected in the Legend 

anchor dropdown at the point specified by Legend placement.  

There are three main elements of a legend: 

• The legend title 

• The legend icon 

• The legend item text 

• The legend background 

Items per row lets you arrange the legend entries.  

Legend icon size sets the size in pixels of a box that your icon will be drawn into. DLC will copy the 

properties of your object into the icon square.  

 

 

Item label offset is the pixel distance between the icon and the item text (#).  
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Label gap is the pixel distance between each item (icon and text) in a row (##). 

Label space is the additional vertical gap between each row of items (###).  

The Draw title checkbox enables the legend’s title.   

The Title style and Item style topics contain parameters adjust the title font, and are the same as in 

section Font 5.2.1.7.1.1. 

The Legend background parameters are the same as in section Background 5.2.1.7.1.2. It draws a 

background behind the entire legend.   

 

To enable the legend, make sure the DLC → Legend → Draw legend checkbox is enabled.  

Each item in the legend is assigned to a ‘slot’. Each object in your chart can be assigned to a slot in 

the legend slot dropdown. Slots are drawn in their numerical order, and are arranged in rows, 

according to the Items per row parameter. If you have objects assigned 6 slots, and you have set 3 

Items per row,  then your legend will contain two rows of three items.  
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Multiple objects can be assigned to the same slot, and are drawn in the same order as objects, as 

determined by the draw order list. In this way, for example, a red curve with green circle markers 

can be shown as one entry in the legend.  

To edit the title of the legend and the text of the items, use the Legend text edit button.  
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8 Data 
 

The Data topic contains the functions that let you import and manage data in DLC.  

 

Copy curve lets you resample date on a chart. To find out more about how to use it, see the section 

10.4 Resample a chart from an image. 

 

The CSV Load button opens a file browser. To find out how to import data into DLC from a CSV file, 

see the section 10.3 Import data from a .CSV file. 

The Manage data function lets you view and edit data that you have already imported into CSV. If 

you have very large amounts of data, this view can take a long time load.   
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9 Objects 
 

The  Objects topic contains all your DLC objects – the drawings of your data.  

 

Draw order lets you move the drawing priority of the objects. Objects are drawn in the order they 

are shown in the list – this means that objects at the bottom of the list will appear to be drawn over  

those higher up. When you change the draw order, the objects are rearranged in the ECP and 

timeline, to reflect that change.  

 

When you click on Add object, a new object is created. You can chose it to be one of a number of 

different types, each of which is detailed in the following sections.  
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9.1 Common parameters 
 

There are a number of object parameters that are common to all types.  

At the top of the topic is the object name. In the following picture, the object name is “Object_1”. 

You can rename the object by clicking the Rename object button.  

 

The Draw object checkbox lets you enable or disable the drawing of the object.  

The Object type dropdown lets you chose the type of object to draw. Each object type has different 

parameters.  

The Legend slot dropdown lets you assign the object to a legend slot. For more information on the 

Legend, see the 7 Legend or Error! Reference source not found. Error! Reference source not found. se

ctions. 

Data dropdowns let you choose the data you imported into DLC. For more information on how to 

import data see the sections 8 Data,  10.4 Resample a chart from an image or 10.3 Import data 

from a .CSV file. 

The Vertical axis parameter lets you assign the object to either the primary (left) or secondary (right) 

axis, which can be controlled independently. By default, the secondary axis features are set to not 

draw.  
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Data drawing functions also have data selection dropdowns, where you can select the data you have 

loaded into DLC. For example, the Curve object type has dropdown menus for the horizontal and 

vertical data of the line it will draw on your chart. Some other object types require more data, for 

instance, for a second vertical data series, or for point labels. 

Some object types let you animate the horizontal and vertical data series. For more information see 

section 10.8 Animate data. 

Disabling the Clip object checkbox allows DLC to draw outside the chart area.  

The Curve trim start and Curve trim end parameters allow you to trim a curve, based on the 

selection in the Trim source dropdown. The options are Distance, H-value and Index.  

If Distance is selected, the range of the trim parameters (0-1) refers to the total length of the curve. 

If H-value is selected, then the range (0-1) refers only to the horizontal value of the curve. This will 

produce unexpected effects if the horizontal data is not sequential. For instance, if the data series 

depicts a circle, there will be two Y points for every X value.  

If Index is selected, then the range (0-1) refers to the total distance of the curve in terms of points. 

For example, in a data series of three points a trim value of 0.25 will appear half way between the 

first and second point, no matter how long the segment of the curve is. This allows you to precisely 

time the appearance of curve features, should you need to.  

The X-offset and Y-offset parameters allow you to move the object. The distance an object moves in 

response to these parameters depends on the setting of the Offset space parameter. There are two 

options: Screen and Chart. The Screen option means that the offset will be pixels – an X-offset of 1 

will move the object 1 pixel to the right. The Chart option means that the offset will be equivalent to 

the objects’ axes – an X-offset of 1 will move the object 1 unit along the horizontal axis, as 

determined by the axis parameters (in the Grid & axes parameters).  

The Duplicate button copies an object. NB: this function also copies the object’s name. 

The Delete button removes the object from the scene.  
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9.2 Curve 

 

The Curve object type takes two series of data: horizontal (or X) and vertical (or Y). These data series 

can be chosen from the Horizontal data and Vertical data dropdowns. 

This is the simplest type of object, and most of the parameters’ functions are explained in the 

section 9.1 Common parameters. 
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9.3 Region 

 

The region object type lets you mark a region in chart space, using min and max X and Y parameters.  

This object type does not require source data.  



Beepee DYNAMIC LINE CHART v1.0 

 

25 
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9.4 Fill 

 

The Fill object type fills the area between a curve ( defined by Horizontal and Vertical data 

dropdowns) and a value specified by the Y-intersect parameter. 

 

You can choose different colors to be shown above or below the Y-intersect. 
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9.5 Label 

 

The Label object type lets you draw labels at the coordinates defined by your data.  
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As with the Curve object type, you can choose horizontal and vertical data using the data 

dropdowns. There is also a dropdown to choose the source of the label’s text or values.  

You can then define the display properties of the labels using the Label font and Label background 

topics. These properties are described in sections Font 5.2.1.7.1.1 and Background 5.2.1.7.1.2. 
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9.6 Marker 

 

The Marker object type lets you put markers at the coordinates supplied by the Horizontal and 

Vertical data dropdowns.  

The Marker type parameter lets you choose the shape. You can select outline and fill properties.  
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9.7 Sprite 

 

The Sprite object type is similar to the Marker object type, but lets you use another layer as the 

source of the marker. You can chose animated or still layers or other compositions as the source.  
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9.8 V-sprite 

 

The V-sprite object is similar to the Sprite type. Vsprite let’s you chose which frame of an animated 

source layer to use, based on one of the other data inputs (horizontal or vertical).  
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The Sprite frame start and Sprite frame end parameters define the range of animation that you 

want to map to the values Sprite value min and Sprite value max. For example, if you have 10 

frames in your video, and you want to map the frames in the source to vertical data which ranges 

between 20 and 80, the parameters might be: 

Sprite frame start: 1 

Sprite frame end: 10 

Sprite value min: 20  

Sprite value max: 80 
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9.9 Area2 

 

The Area2 object type lets you draw an area defined by two curves – one source of horizontal data 

and two sources of vertical data. All three data series must be the same length.  

 

DLC produces a gradient between the two lines’ colors.  
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9.10 Area3 

 

The Area3 object type is similar to the Area2 type, but allows you to use three data sources, and 

produces a gradient between three colors.  
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9.11 Line column 

 

The Line column object type draws thick bars from 0 to the values in Vertical data. 
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9.12 Error line 

 

The Error line object draws vertical lines between the points described by the Vertical data 

parameters. These lines are often used in charts to depict ranges such as confidence intervals.  

 

You can add a cap, using the Cap height and Cap width parameters.  
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9.13 Guide 1D 

 

The Guide1D object does not require data input. It lets you draw a horizontal or vertical line through 

a value set in the Guide value parameter, on the chosen axis. You can also add a label.  

 

The Label topic contains further Label font and Label background topics. These paramters are 

described in sections Font 5.2.1.7.1.1 and Background 5.2.1.7.1.2. 
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9.14 Guide 2D 

 

The Guide 2D object type draws a point defined by the Point to X value and Point to Y value 

parameters. You can turn the point into an arrow and add a label. The arrow parameters are self-

explanatory.  
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9.15 Measure 

 

The Measure object type lets you show the distance in chart space between two points, A & B.   

 

You can move the bar away from the line between the two points using Bar offset X & Y parameters. 

You can also add arrows.  
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9.16 Bar 

 

A Bar object type does not take any horizontal data, and draws bars from 0 to the value of each 

point in the series selected in the Vertical data dropdown. 

 

To use a bar chart, you may want to use a text-based horizontal axis. See section 10.5 Change the 

horizontal axis labels to text rather than numbers for more information. 
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10 How to… 
 

10.1 Find Dynamic Line Chart in the menu & create a new chart 
 

• If you do not already have a composition, click Composition → New  Composition.  

• With your composition active, click Layer → New → Solid. 

• With the new solid selected, click Effect → Beepee → Dynamic Line Chart. 

 

10.2 Set up a spreadsheet for exporting to Dynamic Line Chart 
 

In your spreadsheet application, such as Excel, make sure your data is arranged in columns. DLC 

cannot accept data arranged in rows.  

DLC reads the cells in each row with a hashtag to discover what information is in the cells beneath. 

These are marked with hashtags: #ignored, #type and #data. 

 

#ignored – (e.g. row 1 above) you can write your own notes or comments on a line tagged with 

#ignored. DLC will ignore it. 

#type – in this row (row 2 in the example), you will tell DLC what kind of data is in the column below 

the cell. There are two types: ‘line’ and ‘label’. A ‘line’ type means that the column contains 

numerical data. A ‘label’ type means that the data in the column is text.  

#data – this hashtag (row 3) tells DLC that your data begins on this line. The first cell (cells B3, C3 & 

D3) on the row with the #data hashtag is the name of your data series. A name is required to help 

you identify your data in DLC. The cells underneath the name are the data.  

You can create an animated series of data by giving multiple columns the same name. DLC then 

reads these columns as sequential ‘frames’ of animated data. Each column in an animated series 

must be the same length.  
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To export your data from Excel, save your sheet as a UTF-8 encoded CSV file. This lets you keep a full 

character set, such as symbols and non-western type.  

 

 

Saving from other spreadsheets as a CSV format fil is usually already encoded correctly for CSV. If 

you have problems importing from your spreadsheet application, please raise a support ticket.  
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10.3 Import data from a .CSV file 
 

Look for the data menu item in the DLC Effect Control Panel.  

 

Click on the ‘Load’ button next to ‘CSV’ and navigate to your file.  

When your data is loaded, you will be able to select it from data-selection drop-down menu items.  

 

 

NB: DLC cannot undo a data import.  

 

10.4 Resample a chart from an image 
 

The other way to bring data into DLC is to resample a chart by tracing its lines.  

Start by importing the image of the chart you want to copy the data from into After Effects and 

placing it on your timeline. Make the image large enough that you can accurately copy lines.  

Make sure that the chart image is behind the DLC layer. If the chart background is obscuring your 

chart image, you can turn off DLC’s background in DLC → Screen area → Show background. 

Uncheck the checkbox.  
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Next, use the bottom left and top right handles to match the axes of the DLC chart to the axes of the 

image. You can zoom in to help you match the axes more accurately.  

 

Now you have matched your axis, you can now match the numbers on each chart’s axis.  
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For the X-axis, navigate to DLC → Grid & axes → X-axis → X-axis dimensions and set the min and 

max X axis dimensions.  

For the Y-axis, navigate to DLC → Grid & axes → Y-axis → Y-axis dimensions and set the min and 

max Y axis dimensions.  

You may also want to match the ‘Step’ parameter to adjust the grid lines.  

 

To match the curve on the chart, create a new shape layer and make sure it is above the DLC layer.  

Select the Pen Tool (press G) and begin tracing the curve. 
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When you have finished, you may wish to rename the path in your shape layer so that it is easier to 

identify later on.  

You can now hide the Shape and image layers, leaving only the DLC layer visible.  

To resample the curve, click DLC → Data → Copy → curve Acquire. This will bring up a new 

dialogue: 

 

The dropdown will show all the paths in the composition. If there is only one path in the 

composition, there will be only one choice. Choose your path and click ok.  

DLC will now resample the line, based on the min and max axis parameters you set.  
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You can now check your data by adding a new curve object in DLC. The data dropdowns will contain 

your sampled chart. You can change the dimensions of your chart to your preferences, and the data 

will remain true relative to the axes.  
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10.5 Change the horizontal axis labels to text rather than numbers 
 

NB: THE FUNCTIONALITY DESCRIBED IN THIS SECTION HAS CHANGED SINCE VERSION 1.04.  You 

might not want to use numbers for the axis labels. For example, you might prefer to use the months 

of the year. In this case, you can import a CSV file with your labels. (See the section 10.3 Import data 

from a .CSV file for more information). 

 

To make text axis labels, go to DLC → Grid & axes → X-axis  → X-axis display and change the X-axis 

control dropdown to labels. Then chose the data series with your labels in from the X-axis labels 

dropdown. 
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If DLC → Grid & axes → X-axis → X-axis display → Axis depth is set to ‘Static’, DLC will place the 

labels on the horizontal axis at equal intervals. The distance between the first label and the chart 

area’s left edge will be half the distance between labels.  

Even when the horizontal axis is set to show text, DLC will still use the numerical horizontal axis 

parameters to decide where to draw objects. So to show an object, your object should use a 

horizontal data source that matches the horizontal axis Min and Max parameters, just as you would 

if you were using an axis with numerical labels. You can easily switch between numerical and text 

labels in DLC → Grid & axes → X-axis  → X-axis display using the X-axis labels dropdown 

parameter. 

The exception to this is the Bar type, which doesn’t take a horizontal data. Instead, DLC generates 

horizontal coordinates for the bars based on the number of items in the vertical data, and places 

them on the axis in the same way as it generates text-based axis labels. So if you want a bar chart 

with labels on the horizontal axis that correspond to the bars, the text labels data series should have 

the same number of entries as the vertical data series. 

NEW FUNCTION. If DLC → Grid & axes → X-axis → X-axis display → Axis depth can now be set to 

‘Dynamic’ for text-labels. It doesn’t work in the same way as numerical axis-labels (i.e. ‘zooming’ into 

new depth), but does allow the labels to be constrained to positions on the X-axis.  

In this mode, X-axis labels will begin with an X-value of 1 and increase by one for each element in the 

data. So if you have 10 points in your data, 1-10, and set the min & max of the axis to 1 & 5, the 

points 6-10 will be off-screen (depending on axis label fade settings). 
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10.6 Make a full screen chart 
 

By default, DLC creates a chart that occupies 60% of the screen on each axis, with axis labels on the 

outside of the chart area.  

To make a full screen chart, the top right and bottom left corners of the chart drawing area can be 

dragged to the corners of the composition. Alternatively, the screen dimensions can be altered in 

DLC → screen area → Top right and Bottom left.  

NB: in After Effects’ screen space, vertical coordinates increase from top to bottom – so zero is at 

the top of the screen. 

So to make the chart full screen for a 1920 x 1080 composition, set  

• DLC → screen area → Top right to 1920, 0 

• DLC → screen area → Bottom left to 0, 1080 

The axes’ labels are now outside the chart and screen area. They can be moved inside the chart area, 

and placed next to the edges, or they can be placed next to the axes’ origins.  

 

To move the axes’ labels to the inside the chart area: 

• Set DLC → Grid & axes → X-axis → X-axis display → X-axis location to ‘inside’.  

• Adjust DLC → Grid & axes → X-axis → X-axis labels → Offset to move the horizontal labels. 

• Set DLC → Grid & axes → Y-axis → Y-axis display → Y-axis location to ‘inside’. 

• Adjust DLC → Grid & axes → Y-axis → Y-axis labels → Offset to move the horizontal labels. 

To move the axes’ labels to the origins: 

• Set DLC → Grid & axes → X-axis → X-axis display → X-axis location to ‘On axis’.  

• Adjust DLC → Grid & axes → X-axis → X-axis labels → Offset to move the horizontal labels. 

• Set DLC → Grid & axes → Y-axis → Y-axis display → Y-axis location to ‘left’ or ‘right’, 

depending on which side of the origin you want the labels to be.  

• Adjust DLC → Grid & axes → Y-axis → Y-axis labels → Offset to move the horizontal labels. 

  



Beepee DYNAMIC LINE CHART v1.0 

 

51 
 

10.7 Add dynamic grid depth 
 

In Dynamic axis mode, axis features – grid lines, subdivisions, ticks and labels – are not fixed to 

locations as they are in static mode. As an axis’s dimensions change, a subdivision gridline can fade 

up from transparent, and then fade into a major gridline. This allows a ‘zoom’ into a chart, for 

instance through many orders of magnitude while still showing grid lines at significant intervals.   

 

The axis depth can be chosen in the DLC → Grid & axes → X-axis → X-axis display → Axis depth. To 

make an axis dynamic, change the Axis dept to ‘dynamic’.  

 

The main axis parameters are in DLC → Grid & axes → X-axis → X-axis dimensions. In dynamic Axis 

depth mode, the main grid lines and subdivision grid lines are determined by the ratio of the Step 

parameter to the Subdivisions parameter. For example, if the Step parameter is 100, and the 

Subdivisions parameter is set to 10, the ratio is 10, and DLC will try to draw intervals at multiples of 

ten (and tenths…). 100… 10… 1… 0.1… 0.01…  

In order to do this, DLC needs a minimum value (in pixel space) between potential intervals. This is 

set in the DLC → Grid & axes → X-axis → X-axis dimensions  → Sub distance parameter. DLC will 

not try to draw any axis features when the intervals between them are less than this distance.  
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The distance (in pixel space) at which subdivision gridlines become major gridlines is set with the 

Maj distance parameter.  

The Sub fade in parameter sets how smoothly subdivision gridlines ramp up from fully transparent 

to maximum opacity as the distance between them increases. At 0, subdivisions will not ramp up, 

but will be at maximum opacity if the pixel-distance between them equals or exceeds the distance 

set by the Sub distance parameter. If the Sub fade in parameter is set to 1, then subdivisions will 

ramp from fully transparent at Sub distance to maximum opacity as the distance between 

subdivisions reaches half of the pixel distance between  the Maj distance and Sub distance 

parameters. Put as simply as possible: if you need the subdivisions to ramp in more slowly, increase 

the Sub fade in parameter closer to 1.  

Similarly, the Sub-maj mix in parameter sets how smoothly subdivisions become major features as 

the pixel distance between them changes from the Sub distance parameter to the Maj distance 

parameter. Sub-maj mix in value of 0 means that there is no ramping between the subdivision 

properties and the main gridline properties (and axis labels ramp up from transparent to opaque). A 

Sub-maj mix in value of 1 means that the subdivisions begin transitioning from the subdivision’s 

properties to the main gridline’s properties when the distance between subdivisions is half the 

distance between Maj distance and Sub distance.  

While these parameters seem complex in writing, they are simple in practice. Experimenting with 

zooming chart axes and watching the video guides may be more useful.  
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10.8 Animate data 
 

Some object types let you animate the horizontal and vertical data series. For instance, the Curve 

object has a Vert. animation parameter. This lets you control animation – i.e. which frame of data 

DLC uses.  

To see how to set up data so that it can be animated, see the section 10.2 Set up a spreadsheet for 

exporting to Dynamic Line Chart. 

The value of the Vert. animation parameter determines which frame of the data to show: the 

integer part is the frame, and the non-integer part tells DLC how much to ‘tween’ between the 

frames. If the value of the Vert.animation parameter exceeds the number of frames in the data, 

then DLC uses the remainder of Vert.animation/number of frames. 

 


