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installation

circuitFX

1.                           circuitFX.jsxbin

2.

1.                             circuitFX.jsxbin

2.

                can be run as a dockable panel or as a window.

To install and run as a dockable panel (will be visible in the "Window" menu):

     Copy the file                            into the folder:

    "..Support Files/Scripts/Script UI Panels" (on Windows)

    or "..Scripts/Script UI Panels" (on MacOS) of your After Effects installation.

     Restart After Effects

TTo install and run as a window (will be visible in the File -> Scripts Menu):

     Copy the file                          into the folder:

    "..Support Files/Scripts/" (on Windows)

    or "..Scripts/" (on OS X) of your After Effects installation.

     Restart After Effects

description

circuitFX       is a script for Adobe After Effects, specifically designed to create
graphical circuit boards. The circuit pattern is generated randomly with 
every press of the create button. Apart from the circuit lines and circles, 
circuitFX also creates, chips, resistors and capacitors. It has the ability 
to put all of the needed parts in one shape layer or create seperate 
shape layers for each part of the board. 
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The script can be run as a dockable panel (will be visible and run from the 
“Window” menu of After Effects) or in “window mode” (visible and run 
from the File -> Scripts menu). The mode depends on which folder you in-
stall the script in (see instructions on page 2)

Creates the circuit board!

(when the “Using Masks” mode is
selected this button is replaced with 

two new buttons.
The “Create Grid Guide Layer” and the 
“Create Circuit by Using Masks” buttons.

Adjusts how big the center
empty rectangle would be.

(the percentage is calculated
automatically and depends on the 

GridX and GridY values. This
parameter is only available when
the the “Center-Out” mode is selected)

Set the X and Y
densIty of the grid

(the minimum value is 4 in Fill mode
and 8 in Center-Out mode)

Adjusts the percentage of the 
grid that is going to be used
to populate circuit parts

(minimum value is 10%)

There are three modes of
circuit generation:

_ Fill: The whole composition
is filled

_ Center Out: The formation 
starts from the center, going
ooutwards, leaving
a center rectangle empty.

_ Using Masks: Masks from the 
Grid Guide layer are used to 
mask in/out parts of the
circuit

(circuitFX uses masks that are set to ADD,
SUSUBTRACT or DIFFERENCE mode)

Clicking on the logo brings up
a window with small help tips.

Save/Load Settings Buttons.
You can save/load circuitFX’s
panel settings to a simple
JSON file.

interface 1/3
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The number of Chips, Capacitors and Resistors is automatically adjusted during the generation process. 
For example, if you set the “Populate” and “GridX ” and “GridY” to very low values and set the number of 
Chips to 50, there will not be enough available vertices (positions on the grid) to create all 50 Chips. In 
this case the number of Chips will be automatically reduced (when you hit the “Create Circuit” button) to 
the maximum number of calculated available vertices.

Adjust the number of
resistors to be created

Adjusts the number of
capacitors to be created

Adjust the number of
chips to be created

Adjusts the percentage of 
clusters in the circuit lines 

(clusters are circuit lines with
multiple offsets applied to

simulate parallel circuit paths) Select between 3 types of shapes 
for the start & end of each circuit 
line. (circle, n-gon and cross)

With the N-Gon shape you can create triangles, 
squares, pentagons, hexagons etc

Below are a few examples.

Adjusts the minimum and 
maximum number of

vertices of every circuit line

interface 2/3
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Uses a more complex algorithm 
(slower generation) to prevent 

circuit lines from crossing

Creates an extra solid layer with all 
the generated circuit lines as masks.

Its intended use is to function as a 
source layer for third party plug-ins 

such as ‘Element3D’.

Example of a circuitFX solid layer, used as a 
source in Element 3D.

By default every part of the
circuit board is created
in a single shape layer

By checking this checkbox
every part of the circuit is

put on a different shape layer

Randomizes the trim starting 
point of every circuit line, to 
avoid visible looping patterns

Set the seed to a random value to 
generate a different circuit every 
time you press the "Create Cir-
cuit" button, or use a fixed seed 
value (between 1 and 999999) to 
consistenly generate the same 
circuit.

Creates a temporary composition, 
which prevents After Effects from 
constantly updating the composition 
viewer while generating the circuit, 
thus speeding up the process signifi-
cantly. This temporary composition
is ais automatically removed after the 
successful creation of the circuit.

Also enables the progress bar.

Set the orientation of the
circuit generation and strength 
of the direction.

interface 3/3
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effect controls

adjusts the circuit backplate opacity

adjusts the circuit backplate color

adjusts the overall opacity of the circles

adjusts the stroke width of the circles

adjusts the stroke color of the circles

adjusts the fill opacity of the circles

adjusts the fill color of the circles

adjusts the size of the circles

adjusts the opacity of the lines

adjusts the distance between the cluster lines

adjusts the distance randomness between the cluster lines

sets the color of the lines

adjusts the corner roundness of the lines

adjusts the width of the lines

if checked, the lines are trimmed one after the other

adjusts the trim offset of the lines

adjusts the trim ending point of the lines

adjusts the trim starting point of the lines

set the color of the resistors

adjusts the size randomness of the resistors

adjust the size of the resistors

set the inner color of the capacitors

set the outer color of the capacitors

adjusts the size randomness of the capacitors

adjust the size of the capacitors

set the color of the chips

adjusts the size randomness of the chips

adjust the size of the chips

adjusts the size randomness of the circles

backplate
settings

chips
settings

capacitors

settings

resistors
settings

circles
n-gons
crosses
settings

lines
settings

Once the bar has been created, you will find a number of the following effect 

controls in the effect panel of the shape layer of circuitFX.
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You can test circuitFX free for 7 days. In trial mode these limitations apply:

- Grid X and Y values go only up to 15.

trial limitations

The script is compatible and has been successfully tested on:

- After Effects CC
- After Effects CC 2014
- After Effects CC 2015
- After Effects CC 2015.3
- After Effects CC 2017
- - After Effects CC 2018
- After Effects CC 2019
- After Effects 2020
- After Effects 2021
- After Effects 2022
- After Effects 2023
- After Effects 2024

on bon both Windows and macOs platforms.

compatibility
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1.91  October 17, 2024

    - Fixed: an issue which prevented the generation of circuits in “Using Masks” Mode

1.90   September 15, 2024

    - Optimised: circuit pre-calculation functions are now much faster
    - Optimised: improved support and better error messaging for online activations
    - Optimised: more informative load/save settings dialogs
        - Fixed: an issue where the “mask offset” value was not loaded properly
    - Fixed: an issue where the “Minimum number of vertices” value was ignored on the
          “Center-Out” mode in combination with the “Outwards” orientation
    - Fixed: some UI button issues
    - Added: seed value field + random seed checkbox. You can now set a static seed value and 
           generate the exact same circuit (when all other values remain the same)
    - Removed: support for CS6

1.84   1.84   February 26, 2022

    - Optimised: even faster circuit generating algorithm
    - Optimised: better timing calculations of the progress bar
    - Optimised: new licensing framework
    - Added: load/save settings capability. You can now save/load circuitFXs panel settings to/from  
           a simple .JSON file.

1.80   May 28, 2020

        - Added: support for "Difference" masks mode. circuitFX apart from the "Add" and "Subtract", it  
           also supports "Difference" mask mode. This is an important addition if you are
           converting text-to-masks in order to generate a circuit inside each letter of a word.
    - Added: two new options for start/end shapes of each circuit line. You can now select between 
           Cross, N-Gon and the default Circle. With the N-Gon shape you can create triangles,    
           squares, hexagons etc.
    - Added: size randomness for the start/end shapes

1.75   N1.75   November 18, 2019

    - Added: support for After Effects CC2020
    - Added: support for MacOS Catalina

1.74  August 18, 2019

    - Fixed: a bug where capacitors weren't generated in the "Center-out" mode and when
          "Put circuit parts on separate layers" was enabled
    - Optimised: when the number of chips, capacitors or resistors is automatically reduced by
                            circuitFX (due to small grid sizes or very large numbers of chips/capacitors/
              resistors) the user is informed with a detailed message on why and what was     
                changed
    - Optimised: more efficient generation of chips/capacitors/resistors in all modes
    - Optimised: better labeling, coloring, naming, numbering and handling of generated layers

1.70  July 10, 2019

    - Added: ten (10) more circuit direction options
        - Added: option to generate only the lines coming from the center-out rectangle
    - Optimized: the center-out generation algorithm has been improved and is now
              significantly faster (+30%)
    - Added: option to create a layer with the circuit lines as masks to be used with
           3rd-party plug-ins (such as Element3D)
    - Optimized: redesigned progress bar that is more accurate, more informative,
              and works both in window and in dockable panel mode
        - Fixed: fixed a bug where the circuitFX window would freeze, if very small grid sizes where set

1.60  April 30, 2019

    - Added: support for bezier masks. circuitFX can (finally!) use masks with bezier vertices 
    - Optimized: more compact UI
    - Optimized: more validation checks on UI text fields and sliders
    - Optimized: significantly faster generation of chips, resistors and capacitors
    - Optimized: better compatibility with non-english versions of After Effects
        - Optimized: slightly faster circuit generation algorithm

1.52  March 20, 2019

    - Fixed: some licensing issues
    - Optimized: faster circuit generating algorithm

1.50    April 15, 2018

    - Optimized: significantly faster generation of circuits (by invoking a temporary composition)
               on AE CC2017 and newer versions
        - Fixed: a couple of issues in the UI
    - Added: "Cluster" option

1.40    October 5, 2017

    - Added: size of the grid dots of the guide layer, remain the same, no matter the size of the   
            grid or the size of the comp. Also, an effect control slider has been added to further  
             adjust the size if needed
    - Added: generation orientation direction and strength options
        - Fixed: pasting masks on the guide layer now positions them correctly, rather than
          putting them on the  top left corner (0,0)
    - Optimized: the "Avoid crossing of circuit lines" option is now checked by default on
               tool startup
      - Optimized: circles size, circles stroke width, lines width as well as chips, capacitors and
              resistors initial size in now relative to the  size of the grid
        - Optimized: optimization of the circuit generation algorithm with noticeable speed
                            improvements on all modes

1.31    May 16, 2017

    - Fixed: “Using Masks” mode now properly works even after you close and re-open a project
    - Optimized: faster creation of the grid guide layer

1.30    May 1, 2017

    - Fixed: code optimizations - overall faster circuit generation
    - Fixed: rounding of line corners and trimming, now works properly
        - Added: new circuit generation mode “Using Masks”
    - Added: ability to set min and max number of line vertices
    - Added: After Effects Info Panel now shows detailed info of the circuit generation process
           in real-time

1.02  March 2, 2017

    - Added: option to prevent circuit lines from crossing
    - Optimized: you can now adjust the outer as well as the inner color of the capacitors

1.0    1.0    February 15, 2017

    - initial release

version history



copyright 2024 @ Real Creations

www.realcreations.gr

This script is provided "as is," without warranty of any kind, expressed or implied. 
In no event shall the author be held liable for any damages arising in any way from 
the use of circuitFX.


