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installation

LoadUP!

1.                           LoadUP.jsxbin

2.

1.                             LoadUP.jsxbin

2.

               can be run as a dockable panel or as a window.

To install and run as a dockable panel (will be visible in the "Window" menu):

     Copy the file                          into the folder:

    "..Support Files/Scripts/Script UI Panels" (on Windows)

    or "..Scripts/Script UI Panels" (on MacOS) of your After Effects installation.

     Restart After Effects

TTo install and run as a window (will be visible in the File -> Scripts Menu):

     Copy the file                          into the folder:

    "..Support Files/Scripts/" (on Windows)

    or "..Scripts/" (on OS X) of your After Effects installation.

     Restart After Effects

description

LoadUP!       is a tool for Adobe After Effects, specifically designed to create

loading or progress bars, fast and easy. It is ideal for artists who create HUDs,

UI elements, infographics, charts, TV/News graphics etc.
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The script can be run as a dockable panel (will be visible and run from the “Window” 
menu of After Effects) or in “window mode” (visible and run from the File -> Scripts 
menu). The mode depends on which folder you install the script in (see instructions 
on page 2)

Creates the bar!
The button also shows the
starting and completion
numbers of the bar. Progress bar

(only visible when the script
is run in “Window” mode)

Set the bar width (linear) or
Set the circle size (circular)

Set the bar height (linear) or
Set the circle width (circular)

Select the type of ruler.
The “Linear” option creates
a bar in a straight line.

The “Circular” option creates
a bar in a circle.

Clicking on the logo brings up
a window with small help tips.

Resets all LoadUP!
parameters back to
their default values.

Clicking the Presets button brings up
a window with useful one-click presets.
(more on page 09)

interface 1/5
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Choose the shape of the pointer:

.  triangle.  dot.  line.  squared triangle

Enable/Disable the creation
of a pointer icon.

interface 2/5
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enable/disable the creation
of the text number

enable/disable the addition of
decimals and the number of
decimal digits [none to 10]

set the starting point of the 
numbering (when the bar is empty)

inserts a prefix in front
of the text number

puts each digit of the
text number to a separate layer

set the font size

set the text alignment

set the decimal divider symbol

enable/disable the thousands divider
+ set the symbol for the divider

select the placement of the text number:.  that follows the pointer.  in the center of the bar.  start of the bar (linear only).  end of the bar (linear only).  that follows the pointer - framed
      (linear only)

set the ending point of the 
numbering (when the bar is full)

set the type of the number.  simple number.  simple number + leading zeros.  time/duration [MM:SS].  time/duration [HH:MM:SS].  time/duration [HH:MM]/[TT:TT]..  timecode [HH:MM:SS:FF] @ 24 fps.  timecode [HH:MM:SS:FF] @ 25 fps.  timecode [HH:MM:SS:FF] @ 29,97 fps DF.  timecode [HH:MM:SS:FF] @ 30 fps.  timecode [HH:MM:SS:FF] @ 50 fps.  timecode [HH:MM:SS:FF] @ 59,97 fps DF.  timecode [HH:MM:SS:FF] @ 60 fps..  timecode or frame count of current Comp

inserts a suffix after the 
text number

Thousands Divider

The thousands divider is the 
symbol the separates large num-
bers into groups of three digits.  
It is usually a dot ( . ) but you can 
set it to whatever you like. 

You can have up to 10 decimal 
digits on the text number. You can 
also set the symbol for the decimal 
divider to whatever you like.

You can easily add a prefix 
or/and a suffix to every 
text layer.

Seperate DigitsDecimals Prefix and Suffix

When checked, LoadUP separates every needed 
digit of the text number to individual layers. This 
way you eliminate the annoying “wiggling” you get 
from animating text numbers. In other words it 
converts every font to a mono-spaced font!

You can select between 13 types of numbers. 
From a simple number to complicated time, 
duration and timecode type of numbers.

LoadUP! uses whichever font is select-
ed in the After Effects Character panel 
for every text layers it generates.

Type Setting the font

interface 3/5



page 6

Randomizes only Color Effect
Controls of already created bars.

Randomize All Effect Controls
of already created bars.

Randomize All Effect Controls
except the size

of already created bars.

interface 4/5

TIP: In order for the above buttons to work properly,
you must first select the shape layer of an already created LoadUP! bar in the timeline.
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LoadUP! comes with 40 (20 Linear + 20 Circular) one-click presets for you to choose from.
All one-click presets obey the “Start” and “End” fields in the “number” tab of LoadUP!’s interface.

interface 5/5
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From this tab you can install the custom
effects of LoadUP!

This will add the appropriate entries in the 
PresetEffects.xml of AE CS6 which eliminates 
the 'missing effect:' message on the effects 
control panel.

OnOnce the installation of the custom effects is 
complete and AE is restarted, this tab will no 
longer be visible as it will be redundant.

This tab is only visible and applicable to 
versions of After Effects before CC (v12).
On newer versions of After Effects there is
no need for an installation of custom effects.

interface for CS6 only
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effect controls 1/2

adjusts the tracking, position offset, size 
and color of the text number

enable/disable + adjust
size, distance, placement
and color of the Pointer

enable/disable + adjust
the coverage percentage and

opacity of the Reflection highlight

adjust fill/stroke color & opacity, 
stroke width and offset
of the Back Stripes

enable/disable + adjust
the amount percentage

and color of the Buffering Bar

enable/disable + adjust
the number of copies, size, 

travel amount, angle, color and 
stepping of the Stripes

adjusts the main settings of the bar 
such as width, height, roundness, 

fill/stroke/background color & opacity, 
stroke width & offset

Completion % of the bar (empty to full)

enable/disable + adjust
the amount percentage

and color of the Buffering Bar

Linear Bar

Once the bar has been created, you will find a number of the following effect controls in the effect panel of the shape 

layer of LoadUP. Only the effect controls that are needed are added to the effects control panel. For example, if you 

select not to generate a text number then the “[ TEXT ]: size”, “[ TEXT ]: tracking”, “[ TEXT ]: position offset”, and “[ TEXT ]: 

Color” will not be added as they are redundant.
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effect controls 2/2

Circular Bar

Once the bar has been created, you will find a number of the following effect controls in the effect panel of the shape layer 

of LoadUP. Only the effect controls that are needed are added to the effects control panel. For example, if you select not to 

generate a text number then the “[ TEXT ]: size”, “[ TEXT ]: tracking”, “[ TEXT ]: distance”, and “[ TEXT ]: Color” will not be added 

as they are redundant.

adjusts the tracking,
size and color of the text number

enable/disable + adjust
size, distance, placement
and color of the Pointer

enable/disable + adjust
the coverage percentage and

opacity of the Reflection highlight

adjust fill/stroke color & opacity, 
stroke width and offset
of the Back Stripes

enable/disable + adjust
the amount percentage

and color of the Buffering Bar

enable/disable + adjust
the number of copies, size,

gap, angle, color and
stepping of the Stripes

adjusts the main settings of the bar 
such as size, width, rotation-

fill/stroke/background color & opacity, 
stroke width & offset

Completion % of the bar (empty to full)
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You can test loadUP! free for 7 days. In trial mode these limitations apply:

- The completion percentage on every bar you create, goes up only to 75%.

- The “start” field on the numbers tab is locked to -1.000

trial limitations

The script is compatible and has been successfully tested on:

- After Effects CS6
- After Effects CC
- After Effects CC 2014
- After Effects CC 2015
- After Effects CC 2015.3
- - After Effects CC 2017
- After Effects CC 2018
- After Effects CC 2019
- After Effects 2020
- After Effects 2021
- After Effects 2022
- After Effects 2023
- - After Effects 2024

on both Windows and Mac OS platforms.

compatibility
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1.75   September 19, 2024

   fixed: an issue where the reflection was turning pure white on 32bit color depth comps
    fixed: an issue where double quotes (") on the Prefix and Suffix values were causing expression errors
   added: a third “Randomize” button, that randomizes All Effect controls, except the size (of an already created bar)
   updated: license framework to v4.2.0 + fix for -38 license deactivation error

1.71   August 26, 2020

    fixed: a small bug that prevented LoadUP! from working properly, when run as a dockable panel

1.70   August 23, 2020

   optimised: more compact UI
   optimised: limit the "Font Size" number input in the Script UI panel, to the maximum allowed by After Effects (1296 points)
   optimised: Pointer width and height can now be changed independently in the effects control panel
   optimised: licensing optimisations for Korean Windows Systems
   optimised: when the "Circle Section %" is used, the stripes are now proportionally distanced
    optimised: code concerning "stripes" (copies/travel/gap) has been improved and is now more accurate
   added: "Fill Opacity", "Background Opacity", "Roundness affects tip", "Stripes Roundness" effect control
   added: Stripes Background feature (with Fill, Stroke, Stroke Width & Stroke Color effect controls)
   added: you can now skew the whole Linear Bar
   added: Stepping option. This option makes LoadUP bars fill-up in equal increments
   added: 40 (!) one-click presets with new preset selection interface
   added: “Randomize All” & “Randomize Colors Only” button in the UI
    fixed: text layer position is now connected with the pointer distance value in circular bars (it now works exactly like the linear bar does)
   fixed: the "timecode or frame count of Current Comp" number type, now calculates also the very last frame of the comp
   fixed: several issues with the roundness of shapes (especially at the very start/end of the bar) have been fixed
   fixed: progress bar now works properly
   fixed: several fixes for CS6 users
   removed: "Pointer placement" options from the Script UI panel. Pointer placement can now be changed on-the-fly from the effect controls panel

1.66   November 18, 2019

    added: support for After Effects CC2020
   added: support for MacOS Catalina

1.65   January 5, 2019

   optimised: LoadUP! is now fully compatible with After Effects CC2019
   optimised: more robust text size and tracking calculations when "separate digits" is enabled
   fixed: a bug that prevented negative numbers with decimals to be rendered properly
   fixed: a few UI bugs
    fixed: a bug in the [ Apply ] colors button, which prevented new colors to be applied in circular bars
   changed: the "Set Font" checkbox + text field has been removed. LoadUP! will now use whichever font is selected in the After Effects  Character Panel

1.61   August 18, 2018

   fixed: a small bug fix for non-English AE installations

1.60   August 2, 2018

   added: "Circle Section%" - You can now create circular sections of a loading bar. The "Circle Section %" adjusts how much of a full circle the loading bar should cover.
   added: one additional numbering mode: "timecode or frame count of current Comp".
    optimised: improved box frame positioning code + additional effect controls

1.51   February 25, 2018

   added: Option to install LoadUP! custom effect controls on After Effects CS6, which eliminates the ‘missing effect’ warning.

1.5   January 3, 2018

   fixed: flipped pointer placement
   added: new option for putting numbers inside a box frame
   added: new option for buffering. Every bar has an extra buffering bar (like on-line video player interfaces)
      added: 8 one-click presets (4 of which are interfaces from video sharing sites)
   added: nine (9) additional numbering modes
   optimised: impoved text positioning code
   optimised: custom effect controls have been implemended for a more compact look
   optimised: renamed "Reflection Amount" to "Reflection Coverage %" which is now relative to the bar height.

1.02   December 12, 2017

   fixed: a math rounding issue appearing on very small numbers

1.01   1.01   February 16, 2017

   fixed: a small bug fix for non-English AE installations

1.0     November 11, 2016

   - inital release

version history
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This script is provided "as is," without warranty of any kind, expressed or implied. 
In no event shall the author be held liable for any damages arising in any way from 
the use of ‘LoadUP!’.


