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Effects keep nesting order! 

When you add FX to a nested group and sync, 
it will order the effects as per the nesting 
order. Also, effects of the same type will no 
longer replace each other.

Mask Capabilities! 

Simply add a mask to your Group Control Layer 
and sync. You will see a Set-Matte effect 
applied to the group. You can update the mask 
in any way at any time, just sync if changing 
mask type/lock/invert. You can also put the 
set-matte effect before or after your fx.

Images and videos will be precomposed and 
collapse transformations turned on. 

Reposition group null/anchor point 

To reposition the group null, use the pan-behind 
tool at a time without pre-existing position 
keyframes. Keep the tool selected, and sync 
immediately. Free Compose will delete the key 
made by the pan-behind tool.

Parent-group syncing 

When you add or subtract layers from a group, 
syncing the group will also sync the parent 
group if there is one.

Progress Bars

For small groups, Free Compose is very fast at 
syncing. Larger groups, or groups with heavy 
effects may take longer. I’ve added progress 
bars so you know what’s happening at all times.

  

Important: It will 
not un-precompose 
these layers when 
releasing a group. 

If you require this, 
alt/opt drag your 
footage from the 
project panel to 
the selected 
pre-comp after.
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Installation

Functions

Syncing Groups
(1) Unzip Files.

(2) In After Effects, go to File > Scripts > Install Script, and navigate to
Free Compose.jsxbin, wherever you downloaded it. Restart After Effects.

(3) Start ‘Free Compose’ via the "Window" menu in After Effects.

Make Group

This will take the selected layers and create a 
group from them with your chosen name. 
Technically, it creates a Null Object above the 
selected layers, and an empty shape below 
them, then counts everything in between as 
part of the group. You can rename the group at 
any time but do not remove “Group: #” or put 
any text before it, as this is how Free Compose 
knows which layers are FC Groups. Similarly, do 
not change the name of  “End Group #”. 

The Null Object will be created at the average 
position of the selected layers in either 2D or 
3D space depending on the layers selected.

Layers will be parented to the group (and 
nested groups will be parented to the 
containing group). If you would like to avoid 
parenting, simply hold Alt when you click.

Release Group

If you would like to release a group’s layers, 
you should not simply click the group layer 
and hit delete on your keyboard. You should 
use this ‘Release Group’ button, which will 
release the contained layers and remove the 
effects of that group from those layers. It will 
also remove the ‘End Group’ shape layer.

If you would like to release the group, as well 
as the nested groups contained within, you 
can Alt-click the ‘Release Group’ button.

Show Layers

The ‘Show’ button will show all the layers 
contained in a group. If you would like to show 
only the group layers that are nested within, 
hold the Alt key while you click it.

Hide Layers

The ‘Hide’v button will hide all the layers 
contained in a group. If you would like to hide 
everything but the group layers that are nested 
within, hold the Alt key while you click it.

Select Layers

The ‘Select’ button will select all the layers 
contained in a group, and the group layer itself.

Deselect Layers

The ‘Deselect’ button will deselect all the layers 
contained in a group.

Auto-Sync Vs. Mouse-Over

Whenever changes are made to your group, you 
will want to sync them with the layers. When 
mouse-over is checked, you can do this simply 
by selecting a group and hovering over the Free 
Compose panel. This syncs the number of layers 
in the group, its position in the timeline, effects, 
and stretch. When unchecked, press Sync 1x.

Auto-sync will refresh selected groups every 
100ms, when something has changed. Nice.

Important:
When Auto-Sync is selected, going 
to Layer > Solid Settings or 
Composition > Background color, 
and using the eye dropper will 
cause issues.

When Mouse-Over is checked, you 
can use that eye dropper but you 
cannot click on the Free Compose 
panel with the eye dropper.

(1) Unzip Files.

(2) Copy the file 'Free Compose.jsxbin' into the folder
"Support Files/Scripts/ScriptUI Panels" (on Windows) or
"Scripts/ScriptUI Panels" (on Mac) of your After Effects installation. 

(3) Start ‘Free Compose’ (via the "Window" menu in After Effects)

DO NOT CHANGE. OK to change.

________

Auto Mouse-
over
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Functions P.2
Sync 1x

The ‘Sync 1x’ button will sync the selected 
group’s layers with that group. 

If there have been layers added, Free Compose 
will count them and include them.

If there have been effects applied or removed 
from the group layer, they will be updated on its 
contained layers.

If the group layer has moved time in the 
timeline, its layers will be moved to match.

** If you move a group layer up or down in 
the layer stack, Free Compose will not know. 
To move a group, you must select it, then its 
layers with the ‘Select’ button, before 
reordering them in the stack. This also moves 
the ‘End Group’ layer and any nested groups.

Move Layers

When you move layers from outside a group to 
just below a group in the layer stack, with the 
way ‘shy’ layers work, you may accidentally be 
putting those layers inside the group, instead of 
underneath it and its layers.

If this happens, you can click the left or right 
arrows to move the selected layers outside the 
group either above (left arrow), or below (right 
arrow) the group that they are now contained in.
If they are not inside a group, the script will let 
you know with an alert.

This is also a great way to release 

Auto-Sync

This will automatically sync groups’ layers with 
the group whenever you select one. It checks 
every 100ms to see if something has changed. 

For example, if you have a group selected and 
add an effect, it will immediately apply to the 
layers without mousing over the panel. If you 
move the group’s time in the timeline, the layers 
will immediately follow, if you add layers to the 
group it will update its number of layers 
counter. Checking this unchecks the mouse-over 
syncing. It will not cut the groups layers based 
on the group's in/out point. That is reverse.

** This is nice, but the thing to watch is that 
if you go to Layer > Solid Settings or 
Composition > Background Color and use the 
eye dropper, it will break the script and you 
will have to restart it. You will also have to hit 
undo very quickly twice in succession or stop 
auto-sync to undo.

Help

A couple of tips and reminders, as well as the 
email to reach me at if you have any questions 
or concerns, bug alerts, feature requests, 
compliments, etc.

This little indicator shows whether you are in 
mouse-over sync, auto sync, sync off, or if the 
script is currently syncing.
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Known ways to break Free Compose:

Duplicating Groups without changing the group #... 
I will be creating a function for this in the coming week or two. 

Right now, if you would like to duplicate a group, it is strongly advisable to first change the # in the "End Group #" layer at the end of the duplicated group (always shy'd 
unless shying is off for the comp) to one integer higher than the max group # in the comp. Then, change the # in "Group: # |" for the duplicated layer.

Renaming Groups... 
Renaming groups is possible! Just make sure to only change words after "Group: # |" ... this text is how Free Compose knows a layer is an FC group.

With Auto-sync on...
If you go to Layer > Solid Settings or Composition > Background Color and use the eye dropper, the script will stop and you will have to reopen it.

With Mouse-over on...
You can use the aforementioned eyedroppers as usual, but don't actually click with them on the Free Compose panel.

Moving groups in the layer stack without using the 'Select' function...
If you do this, the End Group Layer may not move with the group, and you will probably end up adding layers in between the original location and the new location to this 
group. This could also cause it to look for layers beyond the number of layers in the composition.

Known ways to break Free Compose:

Duplicating Groups without changing the group #... 
I will be creating a function for this in the coming week or two. 

Right now, if you would like to duplicate a group, it is strongly advisable to first change the # in the "End Group #" layer at the end of the duplicated group (always shy'd 
unless shying is off for the comp) to one integer higher than the max group # in the comp. Then, change the # in "Group: # |" for the duplicated layer.

Renaming Groups... 
Renaming groups is possible! Just make sure to only change words after "Group: # |" ... this text is how Free Compose knows a layer is an FC group.

With Auto-sync on...
If you go to Layer > Solid Settings or Composition > Background Color and use the eye dropper, the script will stop and you will have to reopen it. The problem is modal
dialog boxes stopping the script from running every 100ms. There may be other modal dialogs that interfere.

With Mouse-over on...
You can use the aforementioned eyedroppers as usual, but don't actually click with them on the Free Compose panel.

Moving groups in the layer stack without using the 'Select' function...
If you do this, the End Group Layer may not move with the group, and you will probably end up adding layers in between the original location and the new location to this 
group. This could also cause it to look for layers beyond the number of layers in the composition.
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NEW in V1.2 (installation and all other features on proceeding pages)

Duplicate Groups

With a single group selected, hold the Shift key, 
and click the ‘Make Group’  button.

In/Out Points

Group layers now have an “In” and “Out” marker 
that are used in its layers’ opacity expressions 
to create a virtual in and out for all of them. 
Move these as you would a normal in/out point.

Layers’ opacity and audio levels will now have 
expressions on them. 

For opacity, keep your own expressions inside 
the ‘//YOUR EXP BETWEEN THESE COMMENTS’ 
lines. If you’d like no expression, put ‘value;’

For any newly added layers, refresh or press 
Sync 1x on the group, and it will add 
expressions to layers that don’t have them.

You cannot have a comment block: /* */
inside your expression.

Visibility/Audibility

Group layers now have the ability to turn on and 
off their layers’ audio as  well. When you turn off 
either visibility or audibility for a group layer 
and refresh, it will note what state the layer was 
in, and revert back to that when group visibility 
or audibility is turned back on. This uses layer 
comments separated by ‘|FC|’

Nesting Colour Hierarchy

Nested groups now turn orange for a visual 
queue that they’re inside another group.
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NEW in V1.3 (installation and all other features on proceeding pages)

Frebruary 3 2020 Free Compose V1.4

New UI! 

A more streamlined, compact, pretty version 
with all the same functions. Buttons also 
update more  nicely after being clicked.
Use the >> arrows to switch back to classic if 
you prefer words to icons.

Time Stretching!

You asked, I spent 35 hours delivering. Time 
Stretching is now fully supported except for 
reversing time on the Group Control Layer. 
Simply stretch it as you normally would (you can 
even move it at the same time), and refresh 
with mouse-over/auto/sync 1x. Works for nested 
groups as well. On release, layers/groups will 
take the stretch of the nester group, or revert to 
normal if being brought out to comp level. 

Important: before stretching, just make sure 
no layers are beyond the In/Out point by 
clicking “Sync 1x” button first. 

  

Non-sequential Layer Grouping

You can now select layers in any order to group 
them. Free Compose will move all the layers 
together in order of top to bottom, at the 
location of the top layer and make the group.


