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Rapid Reel Composer is a powerful After Effects script designed to simplify your video 
editing process and enable you to effortlessly create social media reels and short 
videos in just a few clicks. This tool eliminates the need for manually trimming and 
splitting lengthy footage. To split your video into shorter clips, all you need to do is 
place markers by pressing the asterisk (*) key on your keyboard at the desired sections 
of your footage. Rapid Reel Composer will automatically split the selected layer into 
multiple short clips at the marker locations. Rapid Reel Composer is loaded with 
various other convenient features that will save you time and streamline your workflow, 
reducing the need for repetitive tasks. You can use Rapid Reel Composer in Premiere 
Pro using an alternative method.

Installation

Rapid Reel Composer is a .jsxbin file which needs to be installed into the ScriptUI 
Panels folder of the latest After Effects version you are using.

Preferred Method

Download and install the aescripts + aeplugins Manager app. Log in using your
AEScripts.com credentials. Once you have purchased the Rapid Reel Composer script, 
it will appear in the list of available scripts the app will manage the rest for you. 

Manual Installation

1. Download the Rapid Reel Composer zip file and extract the file.
2. Copy the “Rapid Reel Composer.jsxbin” file to the After Effects\Script\ScriptUI 
Panels\ folder.
3. Restart Adobe After Effects.

ScriptUI Panels folder path for Windows and Mac users are different.
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Windows:
C:\Program Files\Adobe\Adobe After Effects <latest version>\Support Files\Scripts\
ScriptUI Panels

Mac:
/Applications/Adobe After Effects <latest version>/Scripts/ScriptUI Panels

Another Installation Method

If you are still confused where to copy the Rapid Reel Composer.jsxbin file, open your 
After Effects, go to File > Scripts > Install ScriptUI Panel. Then select the Rapid Reel 
Composer.jsxbin file and install. Restart your After Effects. Now you can load the script
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from File > Scripts > Rapid Reel Composer.jsxbin. If you don’t find it there, look at 
Windows > Rapid Reel Composer.jsxbin.

Even if that doesn’t work, go to File > Scripts > Run Script File and find the script to 
run. This will make the script undockable.
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In order to run the script in After Effects you will need to enable ‘Allow Scripts to Write 
Files and Access Network’.

Windows:
Edit > Preferences > Scripting & Expressions

Mac:
After Effects > Preferences > Scripting & Expressions

Open support ticket if you are having any issues and report bugs:
https://aescripts.com/contact/#new-ticket

Visit the product page for detail tutorial about the product
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Rapid Reel Composer Interface

	 Set Marker 	 >		  Split Footage	 >		  Organize Clips

Marker Tab:

All marker related helping tools are here. Use these tools to add markers on your clip, 
transfer markers, generate automatic markers, copy markers and so on. Get it ready 
for the next step to split the layers on those markers.

Split Tab:

Split your layers where you set the markers. If you want to be very specific where to 
cut and here to finish the cut, set the markers as In & Out point and use In-Out Reel 
Composer button. If you are feeling lazy to set the out point of your cut, just set a 
marker as in point where to cut it, and mention the duration. Click Lazy button and you 
are done!
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Speed Tab:

After you got your splits, this tab has very useful feature that can help you to organize 
your final video output. You can change the speed of your footage, sequence the 
layers, make fade in fade out slideshows, play with audio volume and so on.

Key Features

• Trim footage based on markers.

• Premier Pro workflow supported: Nest all clips, replace nested footage with After 
Effects project, use the script in After Effects without leaving Premier Pro.

• In-Out: Trim footage to the desired length based on In & Out points.

• Lazy: Automatically trim footage to the desired length starting from the In point.

• Magic Marker: Automatically place markers at the desired intervals.

• Sequence: Easily stagger or overlap layers with a single click.

• Batch Marker Transfer: Copy all selected layers’ markers in a null.

• Speed: Time-stretch layers with a single click to speed up footage.

• Marker Transfer: Copy markers from single layer, paste into multiple layers.

• Layers to Comp Marker: Copy multiple layers markers, send as Comp marker.

• Comp to Layers Marker: Copy comp area markers, send to multiple layers.

• Clear marker comments and/or markers
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• Detect marker's In & Out duration, make comment stats (experimental feature)

• Shift Markers: Shift markers forward or backward by 1 or 10 frames.

• Laptop Markers: Conveniently add markers if you don't have asterisk (*) key.

• BN: Set the work area with a single click for selected layers..

• Precomp: Precompose individually or for all selected layers within one comp.

• Fade In and Fade Out overlapped layers, including audio.

• Adjust or change audio volume with a single click.

• Add adjustment layers of the same length as the selected layers.

• Utilize handy buttons to trim layers.

Getting Started

Before using Rapid Reel Composer script, ensure you have a compatible version of 
Adobe After Effects installed.

This script is compatible with After Effects 2019 (cc 16.1) and later versions.

It may also work on other older versions but some functions may not work as expected.
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How To Use Rapid Reel Composer 1.0
##### Marker Tab #####

<<< Time Tracker And Automatic Marker Generator >>>

<<< Count Markers >>>

The 'Count Markers' button serves to generate statistical insights into the quantity of 
markers present within your selected layers or compositions. When you select layers 
that contain markers, this function provides data on the number of layers selected and 
the total count of markers within those selections.

<<< Marker Duration Button >>>

Please Note: This feature is labeled as experimental and may not function consistently 
on all computer systems.

The 'Marker Duration' button offers a statistical analysis of the markers present in the 
selected layers. It calculates the duration between marker in and out points, assuming 
even-numbered markers as in-points and odd-numbered markers as out-points. 
Subsequently, this function appends a comment to the last marker of each selected 
layer. When multiple layers with markers are selected, it affixes comments to the 
last marker of each layer, along with a comprehensive total duration comment in the 
timeline. Should you reposition any markers and then click the button again, it updates 
all marker comments, reflecting the most current duration.

This feature proves invaluable when working with lengthy footage that boasts numer-
ous markers, particularly when you have specific duration constraints. For instance, 
when crafting reels for platforms like Instagram, where a one-minute duration limit may 
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apply, this tool offers an estimate of the total duration of markers between in and out 
points. It is worth noting that you can exceed your desired duration, creating, for ex-
ample, a 1-minute and 30-second clip. For such scenarios, the 'Time Stretch' feature, 
elaborated on in the 'Speed Tab' section, becomes a valuable resource.

Please Note: On certain computer systems, this feature may not consistently display 
statistics or generate comments. If you encounter such issues, closing and reopening 
the script may resolve them. Given that this is an experimental feature, user feedback 
and bug reports will inform potential improvements or the possibility of its removal in 
future updates.

<<< Magic Marker >>>

The 'Magic Marker' button facilitates the automatic creation of bulk markers on selected 
layers. To employ this feature effectively, ensure you have set the composition's work 
area in and out points.

Within the input box, input your desired quantity, and from the dropdown menu, select 
the unit of measurement, choosing from 'Frames’, 'Seconds’, or 'Minutes’. This value 
dictates the number of automatic markers you wish to generate within the selected 
work area. Even when dealing with cropped layers, this function generates automatic 
markers based on the specified value.

If you prefer to exclude markers from the cropped area, it is advisable to ensure that 
your in and out work area aligns properly with the layer's dimensions. You can set the 
in-point by pressing 'B' and the out-point by pressing 'N' on your keyboard, or you can 
select the layers and simply click on the 'BN' button within the Rapid Reel Composer 
script to define the work area.

Please Note: The 'Magic Marker' feature complements the 'Lazy' button, rendering it 
unnecessary to estimate marker durations. Occasionally, when employing the 'Magic 
Marker' function, your computer's performance may experience temporary slowdown, 
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or the script may appear unresponsive. This tends to occur when working with 
extended footage and applying markers at close intervals. To safeguard your work, it is 
advisable to save your project file before using the 'Magic Marker'.

<<< Clear Marker >>>

The 'Clear Marker' button exclusively removes markers from the selected layers that 
were generated using the 'Magic Marker' feature. Notably, it does not affect manually 
created markers, preserving those markers. Specifically, it removes markers created in 
the previous step, such as markers generated by the 'Magic Marker' button.

For example, if you have generated some markers in a layer using Magic Marker 
button, then manually add few more markers, then again generated markers on the 
same layer using Magic Marker button, the Clear Marker button will only remove the 
last step's markers that you created by using Magic Marker button.

<<< •Clear Comments• >>>

A single click on the button removes comments from markers created by the script, 
specifically those added by the 'Marker Duration' feature. For a more comprehensive 
action, a double-click on the button forcibly removes all comments from markers across 
the selected layers and compositions.

Note: Wherever you see the dot sign in a button, it means that button has multiple 
functions.

<<< Clear All Markers >>>

The 'Clear All Markers' button deletes all markers from the selected layers. Even when 
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manually created markers are present, this function effectively clears them, ensuring a 
clean slate for marker management.

<<< ✱�Button >>>

The asterisk (*) represents the shortcut key for creating markers. If you are working on 
a laptop or using a keyboard without a numpad, this convenient button can save you 
time. Simply select one or multiple layers and click on this button to add a marker at 
the current position. If you wish to create automatic markers, you can use the 'Magic 
Marker' button.

<<< Marker Transfer & Paste Marker >>>

The 'Marker Transfer' button enables the efficient copying of markers from a single 
selected layer. To use this function, select your layer with markers, click the 'Marker 
Transfer' button, and it will copy all markers into system memory. Subsequently, select 
the target layer or layers where you want to transfer the markers and click 'Paste Mark-
er'. This action will copy all of the markers into the newly selected layers. Notably, you 
can copy markers from different compositions as well.

<<< • ‹‹�• Button >>>

This button is designed to shift / move markers on selected layers. A single click will 
move all markers one frame backward, while holding the shift key and clicking will 
move the markers ten frames backward.
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<<< •�››•  Button >>>

This button is intended for shifting / moving markers on selected layers. A single click 
will move all markers one frame forward, while holding the shift key and clicking will 
move the markers ten frames forward.

Note: Wherever you see the dot sign in a button, it means that button has multiple 
functions.

<<< Batch Marker Transfer >>>

When dealing with numerous layers that contain markers and the need to transfer them 
efficiently, the 'Batch Marker Transfer' button proves to be invaluable. Simply select all 
the layers and click the button. This action will generate a null object and copy all the 
markers onto it. Subsequently, you can easily transfer these markers from the null 
object to the composition area or to other layers using the 'Layers To Comp Marker' 
button or the 'Comp to Layers Marker' button.

<<< BN: Set Comp Work Area >>>

After you've created your splits, select all of them and establish the composition's 
work area by pressing 'B' and 'N' on your keyboard. Alternatively, you can simply click 
the 'BN' button in the script to set the work area. Once this is done, you're ready to 
render your video if you don't require any further editing. If you select a layer or layers 
and click 'BN', the composition's work area will be set to the in and out points of the 
very first layer and the very last layer in the selection. If no layers are selected and 
you press 'BN', the composition's work area will be set to the duration of the current 
composition's in and out points.
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<<< Layers To Comp Marker >>>

With the 'Layers To Comp Marker' feature, you can select multiple layers and swiftly 
copy their markers to the composition area in a single click. These markers can then be 
transferred back to multiple layers by using the 'Comp To Layers Marker' button. This 
streamlined process simplifies the management and movement of markers within your 
project.

<<< Comp To Layers Marker >>>

With the 'Comp To Layers Marker' feature, you can efficiently transfer your composition 
markers to multiple layers in a single click. This feature is particularly valuable when 
the need arises to move markers from one composition to another, streamlining the 
process.

##### Split Tab #####

<<< In - Out Reel Composer >>>

The ‘In - Out Reel Composer’ tool is designed for precise video editing. It relies on 
the placement of markers to define In and Out points within your desired layers. In 
this method, odd-numbered markers denote In points, and even-numbered markers 
indicate Out points. This approach is particularly valuable for crafting family videos, 
travel vlogs, and other content where you need meticulous control over the presented 
footage.

For example, if you have a 5-minute video clip and you’ve positioned markers at 3 
seconds, 9 seconds, 40 seconds, 46 seconds, 1 minute 20 seconds, and 1 minute 55 
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seconds on the timeline, the first split will encompass the duration from 3 seconds to 
9 seconds, resulting in a 6-second clip. The second split will be from 40 seconds to 46 
seconds, also 6 seconds in length. The third split will span from 1 minute 20 seconds to 
1 minute 55 seconds, totaling 35 seconds in duration.

To maintain order and organization, each split clip will reside within its precomposition, 
named based on the source clip’s name. A numerical suffix is added to each split clip’s 
name. Furthermore, a new folder called ‘Footage’ is created in the project assets area 
to streamline management. When you apply this method, the main layer becomes 
invisible, and the audio is muted by default. If you need to rectify a mistake or wish 
to remove all the created splits in the current composition, you can simply delete the 
newly created folder from the asset panel. Subsequently, your main layer can be made 
visible again, and you can reapply the script as needed.

<<< Lazy Split Equalizer >>>

The ‘Lazy Split Equalizer’ tool is perfect for quick and effortless video splitting. This 
‘Lazy Method’ only requires the placement of In point markers for efficient splitting. It 
automatically divides the footage based on the markers into segments of a specified 
duration. This approach is well-suited for creating tutorials, speed art, travel videos, 
cooking content, and similar content where you want to share specific moments with 
your audience.

To utilize the ‘Lazy Method’, you need to set an input value (e.g., 10 frames, 10 
seconds, 1 minute) in the provided input box and select the unit of measurement 
(Frames, Seconds, or Minutes) from the dropdown menu. After entering your desired 
value, the tool takes your marker as the In point and splits the footage at that specific 
point. The duration of each split is consistent and determined by your input value.

For instance, if you have a 5-minute video clip and you’ve placed markers at 10 
seconds, 25 seconds, 1 minute 35 seconds, and 2 minutes 20 seconds on the timeline, 
with an input value of 10 seconds and ‘Seconds’ selected from the dropdown, the 
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resulting splits will be as follows: the first split from 10 seconds to 20 seconds, the 
second split from 25 seconds to 35 seconds, the third split from 1 minute 35 seconds 
to 1 minute 45 seconds, and the fourth split from 2 minutes 20 seconds to 2 minutes 30 
seconds. This method is ideal for scenarios where you don’t require precise In and Out 
points, and you want all splits to have the same duration. It’s particularly valuable for 
creating speed art or tutorial videos.

As with the ‘In - Out Reel Composer’, the resulting split clips are placed within their 
own precompositions, named based on the source clip, and organized in the ‘Footage’ 
folder. The main layer is made invisible, and audio is muted by default. To remove 
created splits or rectify errors, simply delete the newly created folder from the asset 
panel.

##### Speed #####

<<< Time Stretch Control >>>

<<< Time Stretch >>>

The ‘Time Stretch’ button is a powerful tool that facilitates the adjustment of video clip 
speeds by stretching or compressing time. It proves valuable for scenarios where you 
want to alter the pace of your footage, such as in speed art, travel vlogs, and various 
other video genres. This feature enables the modification of the speed for multiple 
layers.

To modify the speed of your video clips, you can select a value from the slider or 
input your desired value in the provided box. A setting of 100 represents the regular 
speed, and you can increase the speed by choosing a value below 100 or decrease it 
by selecting a value greater than 100. This tool is particularly useful for ensuring your 
video’s tempo matches your creative vision.
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Consider a scenario where you have 50 small split layers resulting from previous steps 
(marker and split layer steps). To maintain organization, you can precompose these 
split layers into a single precomposition or multiple precompositions. Select all the 
desired split layers in the preferred order, input your chosen value, and click the ‘Time 
Stretch’ button.

After applying the ‘Time Stretch’ feature, each of the layers stretches in time while 
staying in their original position on the timeline. You’ll need to reorder them in a 
sequential manner. For this purpose, the ‘Sequence Layers’ button becomes handy. It 
allows you to sequence your layers based on your selection order, making the editing 
process more efficient.

NOTE: BEAWARE OF YOUR AUDIO! When you speed up or slow down your footage, 
your audio will sound like chipmunk! You can address this by adding background music 
or by re-recording the audio description for your video. Or, you can add your original 
layer back to the footage, disable the eye button for its visibility but let the audio button 
visible.

The ‘Time Stretch’ function is ideal for various scenarios where you want to experiment 
with video speed, and it complements your creative endeavors.

<<< Precomposition Name >>>

Here, you can specify a name for your precomposition, which will be used when you 
employ the ‘Precomp All’ button.

<<< Precompose Individually >>>

You have two options for organizing your clips. You can set markers by pressing the 
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asterisk (*) key on individual clips, or for a cleaner approach, you can select all layers 
and precompose them (similar to Nesting in Premiere Pro).

When you select multiple layers and click this button, each selected layer is 
precomposed into a new composition. These newly created compositions share a 
similar duration and name to the source layers. In your current composition, the original 
layers remain in their respective positions, but they are moved into their individual 
precompositions. This approach allows for precise editing of each clip without affecting 
the original clips.

<<< Precomp All >>>

If you have multiple layers selected, clicking the ‘Precomp All’ button enables you 
to group all the selected layers into a single precomposition. The name for this 
precomposition is derived from the value entered in the ‘Precomposition Name’ box. 
This is a convenient method to streamline your project management, especially when 
dealing with numerous split layers. By selecting all layers from bottom to top and 
clicking ‘Precomp All’, you can efficiently group them into a single precomposition.

<<< Sequence Layers Button >>>

The ‘Sequence Layers’ button is a helpful tool for organizing your layers in sequence 
without leaving any blank spaces. It operates in a manner similar to After Effects’ 
default Sequencer in the Keyframe Assistant menu but offers greater customization 
and ease of use.

Begin by importing your footage and placing it into the composition. To sequence or 
stagger the layers one after another, click the ‘Sequence Layers’ button. Make sure to 
select the layers from the bottom to the top, following the standard editing order in After 
Effects.
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After applying the ‘Time Stretch’ feature, each layer is stretched while remaining in 
its original position on the timeline. Consequently, you’ll need to rearrange them in a 
sequential order. To achieve this, simply select all the layers, ensuring you select 
them from bottom to top, and click the ‘Sequence Layers’ button. This action 
sequences your layers based on your selection order, eliminating the need to navigate 
the Keyframe Assistant menu for layer sequencing.

The ‘Sequence Layers’ button arranges all selected layers directly following the 
first selected footage. If you prefer your layers to be sequenced from the first frame, 
it’s advisable to move your first selected layer to the first frame and then select the 
remaining layers before pressing the ‘Sequence Layers’ button.

<<< Overlap Sequence Button >>>

As the name implies, the ‘Overlap Sequence’ button allows you to set a value to 
determine the overlap between selected layers. The specified value is measured in 
frames. For example, if you input a value of 20, each selected layer will overlap with the 
previous and subsequent layers by 20 frames.

The ‘Fade in’ and ‘Fade out’ checkboxes provide options to create a fade effect for your 
layers, excluding the first selected layer. If you enable the ‘Fade in’ checkbox and input 
a value of 20 in the input box, each selected layer will have a 20-frame fade-in, coupled 
with the overlap between layers. This feature adjusts the opacity values of all selected 
layers, creating a smooth fade-in effect.

To restore the visibility of all layers and remove opacity keyframes applied through the 
‘Fade In’ and ‘Fade Out’ feature, you can utilize the ‘Clear Opacity’ button located at 
the bottom right of the panel. This button resets the opacity properties for all selected 
layers, making them 100% visible and removing any opacity keyframes.
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<<< Trim In & Trim Out Button >>>

Located beneath the ‘Overlap Sequence’ button, the ‘Trim In’ and ‘Trim Out’ buttons 
serve a straightforward purpose. By selecting your desired layer or layers and 
positioning the timeline indicator where you want to trim, pressing the corresponding 
button will trim the footage at that point. This allows you to make precise adjustments to 
the In and Out points of your footage as needed.

<<< Add Adj. & Del Adj. Button >>>

Add Adj. is Add Adjustment Layers. Del Adj. is Delete Adjustment Layers.

The ‘Add Adj’. button facilitates the addition of adjustment layers to one or multiple 
selected layers, ensuring they match the duration of the source layers. This is a time-
saving option for enhancing the visual quality of your layers or applying effects 
consistently across multiple layers. Conversely, the ‘Del Adj’. (Delete Adjustment 
Layers) button enables the removal of any adjustment layers from selected layers. It 
automatically identifies and deletes adjustment layers from the selected layers without 
the need for manual selection.

<<< •Fade🎵• >>>

The ‘Fade Music’ button is a versatile tool with multiple functions. It allows you to 
change the audio volume level for multiple layers and create audio fade-in and fade-out 
effects.

To adjust the audio volume level for selected layers, input your desired value in the 
input box adjacent to the ‘Overlap Sequence’ button. If you wish to decrease the audio 
volume, you can use a negative value in the input box. Clicking the ‘Fade Music’ button 
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will apply the volume adjustment. Any existing keyframes in the audio properties of the 
selected layers will be replaced with the new value.

For creating fade-in and fade-out effects, input your desired value in the input box and 
check the ‘Fade in’ and/or ‘Fade out’ checkboxes. There’s no need to input a negative 
value in the input box because the script automatically determines whether to apply 
fading in or out based on your checkbox selection. This feature adds keyframes for 
the fade-in and fade-out effects. The fade-out value is placed at the end of the layer. 
So if you have a music layer and you want to fade out before the track is finished, you 
should trim the layer same as your desired duration, then use the Fade Music button to 
fade in or out. This allows you to smoothly transition audio in and out.

<<< Clear Time Stretch Button >>>

The ‘Clear Time Stretch Button’ is a convenient tool for reverting any time stretching 
modifications applied to your layers back to their original state. Simply select all the 
layers you want to reset Time Stretch, press the ‘Clear Time Stretch’ button and it will
reset the time back to normal. You can keep playing with the Time Stretch slider, Apply 
Time Stretch, and Clear it out to experiment your desired footage speed. The regular 
speed value is 100. If you go below 100 then the footage will be fast, if you choose a 
value greater than 100 then the footage will get slow down.

<<< Clear Opacity Button >>>

The ‘Clear Opacity’ button is designed to remove all fade-in and fade-out keyframes 
from the opacity properties of selected layers. It’s particularly useful if you’ve applied 
the ‘Overlap Sequence’ option with fade effects and later decide to eliminate all opacity 
keyframes. This action restores the visibility of the layers to 100%.
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Premiere Pro Workflow

Rapid Reel Composer enhances video editing by integrating with Adobe Premiere Pro 
and After Effects. While it doesn’t load directly into Premiere Pro, it complements a live 
action workflow.

•	 Import your footage into Premiere Pro.

•	 Create sequences from your clips by selecting them, right-clicking, and choosing 
‘New Sequence From Clip’.

•	 Group all your footage by selecting them in the timeline, right-clicking, and choosing 
‘Nest’.

•	 Rename your nested composition as needed and select it.

•	 Right-click on the nested composition and select ‘Replace With After Effects 
Composition’.

•	 After Effects will open, and you’ll be prompted to save the After Effects (.aep) file.

•	 In After Effects, add markers by pressing the asterisk key (*) and use Rapid Reel 
Composer for your editing needs.

•	 Save the .aep file when your editing is complete in After Effects.

•	 Your Premiere Pro project will automatically update, allowing you to return to 
Premiere Pro for further edits.

•	 Watch the tutorial on the product page for details.
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Troubleshooting

Most of the problems are resolved by closing the script, reload it and restrat After 
Effects.

<<< Marker Duration Button >>>

THIS BUTTON IS EXPERIMENTAL. THIS MAY NOT WORK ON SOME COMPUTER.

Sometimes Marker Duration Button may not show you the result as expected. Close 
the script and reload it. 

Sometimes you may get ‘No composition is active or no layers are selected’ alert even 
though you have layers selected. Close the script, select all of your desired layers and 
reload the script again.

Note: Some computer may fail to show the stats and produce the comment about the 
duration. You may try to close the script and re-open to see if the issue if fixed. As 
this is an experimental feature, we may improve it or completely get rid of it in future 
updates, based on user bug reports and feedback.

<<< Apply Magic Marker Button >>>

Sometimes when you apply magic marker, the computer gets slow down or the script 
seems stuck. It happens when you have a long footage and you want to apply markers 
on frames with very close value. It creates a lot of markers that makes your computer 
slow and even crash the software. So please save your project file before you apply 
Magic Marker.
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<<< •Clear Comments• >>>

If the button doesn’t work, closing the Rapid Reel Composer script and restart after 
effects may fix the problem. If you still have problems, get a ticket from product page 
and report the bug. We will try to fix it on the next update.

<<< Other Issues >>>

If you have issues with running the script, make sure Expressions Engine for the 
project is set to JavaScript.

To do that, go to File > Project Settings > Expressions Engine > JavaScript

Also, in Edit > System Preferences > Scripting & Expressions, check ‘Allow Scripts to 
Write Files and Access Network’.

For Mac, go to After Effects > System Preferences > Scripting & Expressions, check 
‘Allow Scripts to Write Files and Access Network’.

If you encounter any issues other than above mentioned points while using Rapid Reel 
Composer,
please report about the bug and issues in detail. I will try to fix it and update on the next 
version.

Open support ticket if you are having any issues and report bugs:
https://aescripts.com/contact/#new-ticket

https://kupucreativemedia.com/
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Support & Contact

If you have questions, need assistance, or want to provide feedback, please don’t 
hesitate to reach out.

Open support ticket if you are having any issues and report bugs:
Open Rapid Reel Composer, go to ‘?’ tab, click on ‘Registration’ button.
Then click on ‘Get Support’ button to get a new ticket and report bugs.

Or go to the webpage below -
https://aescripts.com/contact/#new-ticket

Visit the product page for detail tutorial about the product

https://aescripts.com/rapid-reel-composer/
https://kupucreativemedia.com/products/

Legal Information

Please review our latest End-User License Agreement (EULA) for terms and conditions 
regarding the use of Rapid Reel Composer.
You can find the latest EULA at the product page.
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End-User License Agreement (EULA)

Last updated: 15 November 2023

Please read this End-User License Agreement (‘Agreement’) carefully before clicking 
the ‘I Agree’ button, downloading or using Rapid Reel Composer (‘After Effects Script’).

By clicking the ‘I Agree’ button, downloading or using the After Effects Jsx Script File, 
you are agreeing to be bound by the terms and conditions of this Agreement. If you do 
not agree to the terms of this Agreement, do not click on the ‘I Agree’ button and do not 
download or use the Application.

<<< License >>>

MD Akhteruzzaman (Kupu Creative Media) grants you a revocable, non-exclusive, 
non-transferable, limited license to download, install and use the After Effects Jsx 
Script File solely for your personal or commercial purposes strictly in accordance with 
the terms of this Agreement.

<<< Restrictions >>>

You agree not to, and you will not permit others to:

a) license, sell, rent, lease, assign, distribute, transmit, host, outsource, disclose or 
otherwise commercially exploit the After Effects Jsx Script File or make the After 
Effects Jsx Script File available to any third party.

<<< Modifications to Application >>>

MD Akhteruzzaman (Kupu Creative Media) reserves the right to modify, suspend or 
discontinue, temporarily or permanently, the After Effects Jsx Script File or any service 
to which it connects, with or without notice and without liability to you.

https://kupucreativemedia.com/
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<<< Term and Termination >>>

This Agreement shall remain in effect until terminated by you or MD Akhteruzzaman 
(Kupu Creative Media).

MD Akhteruzzaman (Kupu Creative Media) may, in its sole discretion, at any time and 
for any or no reason, suspend or terminate this Agreement with or without prior notice.
 
This Agreement will terminate immediately, without prior notice from MD 
Akhteruzzaman (Kupu Creative Media), in the event that you fail to comply with any 
provision of this Agreement. You may also terminate this Agreement by deleting the 
After Effects Jsx Script File and all copies thereof from your mobile device or from your 
desktop.

Upon termination of this Agreement, you shall cease all use of the After Effects Jsx 
Script File and delete all copies of the After Effects Jsx Script File from your mobile 
device or from your desktop.

<<< Severability >>>

If any provision of this Agreement is held to be unenforceable or invalid, such provision 
will be changed and interpreted to accomplish the objectives of such provision to 
the greatest extent possible under applicable law and the remaining provisions will 
continue in full force and effect.

<<< Amendments to this Agreement >>>

MD Akhteruzzaman (Kupu Creative Media) reserves the right, at its sole discretion, to 
modify or replace this Agreement at any time.

<<< Contact Information >>>

If you have any questions about this Agreement, contact: 
hello@kupucreativemedia.com
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Thank you for choosing Rapid Reel Composer! I hope it enhances your After Effects 
experience and helps you achieve your creative goals.

MD AKHTERUZZAMAN (Kupjoler Manush)
Sydney, Australia
Kupu Creative Media
https://kupucreativemedia.com/
https://aescripts.com/rapid-reel-composer/
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