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Installing and Running the Script
Installation
The script can be run separately or as a panel inside After Effects.

To use the script as a panel, first copy the scripts into the After Effects ScriptUI Panels directory:
On Windows:

C:\Program Files\Adobe\Adobe After Effects <version>\Support Files\Scripts\ScriptUI Panels\

On OS X:

MacHD/Applications/Adobe After Effects <version>/Scripts/ScriptUI Panels/

Running the Script
To run a stand-alone script, choose File > Script > Run Script and navigate to the folder where your
script is located.

To open a script as a panel, copy the scripts to the After Effects ScriptUI Panels directory, and choose
Window > Conform Studio.jsx or any other script from the list. Any Conform Studio script can be
opened as a panel.

Compatibility
Trim N Collect script was tested on CS6, CC and CC 2014, but it’s possible that they will run on the
earlier versions, starting with CS3 as well. You will not be able to invoke stand-alone scripts before
CS5.5 though, as the distributed files are of jsxbin type, and the option to run jsxbin files via File >
Script > Run Script was added in CS5.5.
If you find the scripts not compatible with the AE version you are running, contact me at
bart@creativeimpatience.com.

Troubleshooting
If you experience problems running the script, please use the aescripts + aeplugins forum and support
system. This is the best and the surest way to receive the needed support.
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Trim N Collect

Trim N Collect will prepare your project for backup and/or archive by removing unused media and
trimming the used clips only to the ranges used in the compositions.

Target
Trim N Collect operates on the project file.

How it works
The script performs the following operations:

1. Saves the project in the destination directory.

2. Finds all compositions in the project.
3. Runs user scripts.

4. Reduces project (Files->Dependencies->Reduce Project).

5. Consolidates project (Files->Dependencies->Consolidate All Footage).
6. Gathers information about all media used in the project.
7. Trims and/or transcodes the footage.

8. Replaces the original media with trimmed media, including keyframes, especially time remapping
and speed ramps.
9. Copies all other (non-video and non-audio) files into the destination directory.

To run the script simply press the Proceed button once you select your trim and collect settings.
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Basic settings
The first tab (Settings) shows a set of basic settings.

Destination directory
You can choose your destination directory by pressing the Browse button.

By checking the Create subfolder named like the project file option, the appropriate directory will
be created in the destination folder and the script will be saved there.

Transcoding templates
The scripts reads all render settings and output presets settings present in your installation of After
Effects and lists them under three dropdown menus. These settings are applied to video media that
needs to be trimmed and optionally to image sequences. There are three menus in this group:
Render settings will be applied to all transcoded footage. It is advisable to create a setting with a
desired bit depth (for example 16-bit or 32-bit float) to make sure that you retain as much data as
possible from your original media.

Files without alpha channel output preset will be applied to all files which do not have an associated
alpha channel. It is fine to select here a preset that does not preserve alpha channel, like ProRes 422.

Files with alpha channel output preset will be applied to all files which do have an associated alpha
channel. You should select here a preset that will preserve the alpha channel information, for example
ProRes 4444.

Handles
Check the Add handles box to add a number of frames specified in the text field that follows to add a
certain number of frames to each trimmed media.

Consolidate gaps
This option makes sure that the script will consolidate into a single media file all instances that are not
separated from each other for more than the specified number of seconds. Otherwise the script will
consolidate only the overlapping media files. (note: this is a change from version 1.0.1)

Save as defaults
This button will save currently selected basic settings, with the exception of the destination folder, to
disk. Next time you run the script, these settings will be restored.

Processing settings
The second tab (Processing) contains more advanced options.

Initial scripts
This is a list showing names of the scripts that will run right after the project is saved to the
destination directory. These scripts must not rely on anything being selected or active. Usually they
will create a folder structure, establish project bit depth, etc. The scripts will be executed in the order
they are placed on the list. There is no limit on the number of scripts that can be added.
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To add a script, click the + (plus) button to the right of the list. A dialog will open asking you to find
the jsx or jsxbin file. No other files are accepted. To remove a script, select it from the list, and then
click the activated - (minus) button to the right of the list.

Image sequence processing
Sometimes you might wish to treat your image sequences different than your video files.

Transcode image sequences will transcode the image sequences (with exception of exr files) the
script encounters using the template presets, depending on them having or not the alpha channel. By
default image sequences are only trimmed, not transcoded.

Transcode OpenEXR sequences will transcode the sequences of multichannel exr files using the
template presets, depending on them having an alpha channel. Note, that if the exr files are truly
multichannel, you are going to lose the multichannel information by transcoding! This option is off by
default, which means that the exr sequences are only trimmed.

Trimmed footage management
This panel is dedicated to managing the trimmed footage.

Transcode full range media checkbox allows you to choose if the files which are used in the project
in their entirety (including handles) should be transcoded or just collected. By default this option is off
to allow for faster processing, but if you are using formats that take up a lot of space, you might want
to turn this option on.

If the Import trimmed footage checkbox is turned off (default), the media files are imported next to
originals. If it is turned on, they are imported into a single folder in the project structure, named based
on the information in the textbox below.
There are two ways to specify the folder. You can enter its name or even the path towards it manually,
for example: footage will move the composition to the footage folder in the project root, and
footage/trimmed will move it to the trimmed folder in the footage folder in the project root.
Alternatively, you can select a folder in the project panel and then press the << button. The path to the
folder will be saved in the textbox.

Collect options
There are several options which allow you to customize the process of file collection.

Collect C4D files (without dependencies) will copy also Cinema 4D project files present in the
current After Effects project to the destination. However, it will not perform the asset collection
within c4d project itself, like the Collect option in After Effects CC 2014.1 and above does. You will
have to copy the textures present in the c4d project by yourself.
Copy entire image sequences will copy whole image sequences instead of trimming or transcoding
them. Turning this option on will gray out the Transcode image sequences option from the Image
Sequence Processing group.

Copy entire OpenEXR sequences will copy whole sequences of exr files instead of trimming or
transcoding them. Turning this option on will gray out the Transcode OpenEXR sequences option
from the Image Sequence Processing group.

Do not collect files will not perform the collect operation at all, instead only trimming and
transcoding the used parts of the footage to the destination folder. If you want to collect the files, you
must remember to make a manual collect later. This option can for example be useful if you want to
use the File->Dependencies->Collect Files… functionality to save the c4d projects with their assets.
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Save as defaults
This button will save the processing options as defaults, which will be restored next time you run the
script.

Advanced settings
The third tab (Advanced) contains advanced settings that you should adjust with extreme caution,
because they change the default way the script operates.

Custom file extensions to be treated as image sequences
After Effects does not expose the type of imported media file to the scripting engine. Image
sequences are recognized based on the file extension, and so far include:
dpx, psd, tif, tiff, jpeg, jpg, png, bmp, tga, jp2, j2k, jpf, jpx, ari, dng, rgb

This field allows you to add your own custom extensions to the list, so that the script processes these
files accordingly.

Supress render messages
During trimming, render queue can display a number of moderately annoying messages. Some
of them are important, some of them not so much. By checking this option, you can turn off the
verbosity of After Effects render manager. Off by default.

Save as defaults
This button will save the advanced options as defaults, which will be restored next time you run the
script.

7

Known Limitations
Pulldown
This script will not process pulldown correctly. If the pulldown footage is detected, it will display a
warning and close the project. If you need pulldown support, please contact me, but at this moment I
don’t have it on the roadmap, as it requires a tremendous effort to cover this relatively rare case.

Time remapping
You might experience two issues using this script. One is the timecode shift, another is a subframe
variation for time-stretched layers.

The timecode shift will occur randomly in the media that has the starting timecode larger than
roughly 09:00:00:00. You might experience a shift by one or two (if the starting timecode is higher
than 19 hrs) frames. For example, the original layer will read 16:57:06:11, but the rendered layer will
read 16:57:06:12 on the same frame. This is unfortunately an After Effects bug, and there is nothing
we can do do fix it - the ball is in Adobe’s court on this one. Note, that this will only be present in the
video files, and the image sequences are not affected by it. If this is a deal-breaker for you, use image
sequences.
The layers will be perfectly aligned, it is only the timecode value that will be different.

The subframe variation for time-stretched layers might occur when the layer is time-stretched, and
the trimming occurs on the frame that should have a fractional frame value. Unfortunately, this is
pretty common, and this version of the script does not have the option to intelligently trim the layers
to make sure that the Time Stretch is perfectly aligned. The variations should however reach up to
half of a frame. For most purposes this difference is going to be negligible, unless you are doing a roto
on the time-remapped layers.

Manual confirmation for each import of dng files
Due to the way After Effects imports cdng and dng files, it will be necessary for you to manually
accept the CameraRAW settings dialog that appears each time the file or sequence of files is
imported. It’s usually enough to press enter each time the dialog appears or use the mouse, but it
might make the trimming a bit more tedious, and prevents from fully automating the task.
You will be notified the first time the dng file is found in your project.

There is nothing we can do about it, except pester Adobe to remove the dialog.

Effects that use arbitrary data
Some effects, like Liquify, do not use standard data types and therefore scripting cannot read and
write their values. Since moving keyframes in time requires removing the old one and adding a new
one with the same value, these keyframes effectively cannot be moved by Trim N Collect.

To circumvent this issue, the script will precompose the layer with the offending effect, and perform
media replacement in the precomposition. This is not the most elegant solution to the problem, but it
does work. Adobe folks responsible for scripting have been notified, and we know that we’re not the
only ones asking for the feature to move keyframes, so perhaps we will see an improvement on this
front in the future versions of After Effects.
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Layered PSD files
After Effects does not allow scripting to access layers in psd files, and automatic replacement would
wrongly show a composite image. Therefore, if the script detects the usage of such files, it will display
a warning and switch to manual collect mode (equal to checking Do not collect files option). You
will have to perform the manual collect yourself. We apologize, but there is nothing that we can do to
improve this.
Note, that the automatic recognition is based on two conditions:
1. The file must have a psd extension.

2. The source item (not the comp layer, but the project item) must have a slash (“/”) in its name,
which is the default naming scheme that After Effects uses when importing psd layers as separate
items.

If any of these conditions is not met, the script will not recognize the layered psd files, will not display
a warning and will not switch into the manual collect mode. If you have a habit of renaming the
project items (not composition layers, these are not checked) or not using the psd extension, you have
to remember to check the Do not collect files option yourself and perform the manual collection
afterwards.
Finally, this only affects layered psd files imported as separate layers. Merged files are relinked
without issues.

C4D asset collection
CC 2014.1 update added a great functionality to manual collect – it will traverse the c4d files and
look for texture files linked in them, and copy them to the collect folder as well. Unfortunately, this
functionality is not presented to the scripting engine, thus not available at the moment of the release.

If you are depending on this functionality, I recommend you check the Do not collect files option and
perform the manual collect once the process finishes.
Optionally, if you are interested in getting this functionality coded into Trim N Collect script. contact
me at bart@creativeimpatience.com, and we can talk. It’s possible, but it requires low-level coding
and a custom setup.
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Final Remarks
Thank you for trying out or buying Trim N Collect. We tried very hard to bring you the product
that will make your life easier, and save you hours of menial work. If for some reason we had not
succeeded, the surest and quickest way to obtain support is to use the support mechanism on
aescripts+aeplugins website:
aescripts.com/contact/

feedback
If you have some ideas that would make your life easier or you feel some features are missing, feel free
to contact me at bart@creativeimpatience.com and we’ll be happy to hear your thoughts, and work
towards a solution.
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Change Log
1.1.4
Release date: Apr 11th, 2017

Fixed: Layers without time remapping capability no longer cause the script to hang.
Creative Impatience rebranding

1.1.3
Release date: Oct 23rd, 2016

Added: Pulldown warning. The script will terminate upon encountering footage with pulldown.
Fixed: Correct render queue behavior for AE versions 13.0 and above.
Fixed: Layers with tracking mask would switch places after replacing.

Fixed: Same file in different places would prevent the script from rendering.

1.1.2
Release date: Apr 10th, 2015

Fixed: Sometimes the script would stop during footage replacement.

1.1.1
Release date: Mar 17th, 2015

Fixed: dng warning appears when there are no dng files in the project
Fixed: Animated masks could cause the script to fail

Added: Layered Adobe Illustrator ai files will generate psd/ai warning and switch to manual collect
mode.

1.1.0
Release date: Feb 3rd, 2015

Added: Create folder based on the project name option

Added: Custom extensions to be treated as image sequences input
Added: Option not to transcode media that wouldn’t be trimmed
Added: Option to supress render messages

Added: Automatically consolidate overlapping media
Added: rgb file extension added to image sequences

Added: Layered psd files switch processing to manual collect mode
Added: Known limitations for layered psd files

Added: Known limitations for effects with arbitrary data

Fixed: Effects using arbitrary data would cause the script to fail
Fixed: Time remapping would cause the script to fail
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Fixed: Consolidate with value 0 would not consolidate all gaps
Fixed: Gaps were not always consolidated

Fixed: Parenting to media layer would disappear when the media was replaced

Fixed: Expressions based on layer names would become invalid after media was replaced

1.0.1
Release date: Jan 15th, 2015

Fixed: Dot in the filename would truncate the filename to the first dot.

1.0
Release date: Jan 11st, 2015

Initial release
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