• Hello Eddie,
    Longshadow is working in 2d space, you can treat it as an image effect which changes layer bounds. To do 3d with it, please use precomps.

    Also, please, for feature requests and bug reports file bug tickets, it's much more easy to support users and track bugs that way.


  • Is it possible to make the maximum of Grow Layer Bounds, px more than 1000?
  • It totally is in theory, but it would effectively made the plugin working at about 4k resolution minimum, that would be rather slow or potentially even crashing the driver on cheaper GPU cards. So we decided to stop at 1000.
    Dunno, we can extend it by some value, but the issue and people with Macs and just slower GPUs won't go anywhere.
    So far we recommend just using precomps for everything that Grow Bounds isn't suitable for.
  • Hey guys

    long shadow is working in my comps but its not rendering in my final outputs?

    Any solution?

    Thanks
  • Hi Jason,
    Well, Longshadow is used by quite many people and this is first time I hear about such issue, as far as I can remember.
    If you wish, you could file a bug ticket, describe your problem there and add an example case.
    Please file a bug by this link.

  • Hey there. Love the plugin. Huge time saver.

    When I have Longshadow on a precomp layer....and a layer is fading out within the precomp....the long shadow just toggles off from 100>0. It doesn't fade out with the layer.

    is there a way around this?

    Thanks!
  • Hi Bob. Well, seems you are fading the source layer for the plug-in, so it works as usual unless at some point it decides that the source alpha is too low and so it shouldn't cast shadow. So you better fade out alpha AFTER the plug-in - either with extra precomp or with some alpha modifying plug-in inserted into the effects stack after Long shadow.
  • Thanks for reply. Didn't expect such a quick turnaround :)

    ignore my bug report I sent in.

    Basically LS can't see alpha fade, right? I understand what you mean by putting it before the fade.
  • Hi Bob. Well, seems you are fading the source layer for the plug-in, so it works as usual unless at some point it decides that the source alpha is too low and so it shouldn't cast shadow. So you better fade out alpha AFTER the plug-in - either with extra precomp or with some alpha modifying plug-in inserted into the effects stack after Long shadow.
    What would be an Alpha modifying plugin to do this? Maybe that's quicker than rebuilding all the precomps again

    The problem I'm having is that I have time remapped multiple comps with fades inside the precomp. So adding a Longshadow inside each of these is a bit laborious and affects the timing of the long shadow keyframes as well (all in in all a bit confusing)

  • LS just knows about pixel values in its input layer, and either drops shadow from particular pixel or not depending on it. I am way far from PC right now and can't say off the top of my head which standart plug-in does what I am suggesting, but quite sure there was such thing. Or you could use something from the channel operation directory of your effects list and eg use some additional solid layer color as the alpha source.
  • I'm having an issue where if 2x post processing I'm getting a pink X across my text. As soon as I turn it off it disappears. It is registered.
  • Hey Thomas. Could you please try purging your cache?
  • I grabbed a demo of this plugin and I'm seeing the same thing as Sébastien Bruzzo below. The supersampling creates a weird sub-pixel dark line around the shadow and doesn't make the edges look much less aliased. Any plans on improving this in the future?
  • Hi Sam, we're working on improved rendering algorithms that would make these problems go away, but either way what you're saying sounds strange. Supersampling shouldn't create these type of artefacts. Please file a bug ticket and attach example project to it. 
  • Can not cc2018 version?
  • is there any help anywhere to explain how to create some of the looks in the demo video?
  • Hey!
    CC2018 works just fine!
    Mark, what exactly would you want to know?
  • When I'm using the fade out effect on copy and it's a light colour I seem to be getting a dark streak in the gradients. Is there any tutorials in avoiding this? I'm blending orange and yellow.

    image
  • Hey Paul, sorry, can't really imagine what's that. Could I ask you to file a bug ticket and attach a picture/example project to it, please?
    When I'm using the fade out effect on copy and it's a light colour I seem to be getting a dark streak in the gradients. Is there any tutorials in avoiding this? I'm blending orange and yellow.

    image

  • Will there be an update for Catalina?
  • Just a heads-up... I tried downloading the demo (via the "Try" button). Installed per included instructions, but upon launching After Effects, it just gives a message that the plugin is damaged and my only option is to move it straight into the trash.
  • Hi Jason,
    Oh, sorry for that. Are you sure you've tried latest version (1.14.1)? Also, are you on Catalina? 1.14.1 is an update for Catalina that is supposed to exactly not do that.
    If above facts are true, may I ask you to file a bug ticket with some details about your config?
    Just a heads-up... I tried downloading the demo (via the "Try" button). Installed per included instructions, but upon launching After Effects, it just gives a message that the plugin is damaged and my only option is to move it straight into the trash.

  • To all Catalina users: please note that you either need to:
    - remove quarantine attribute from plugin file to make it work on Catalina (xattr -r -d com.apple.quarantine LongShadow.plugin), if you're downloading it manually and putting it into plug-ins folder
    - or, you can just use AEScripts manager app to install plugins automagically.
    We're not happy about it, but seems like there are no other options for now.
  • To all Catalina users: please note that you either need to:
    - remove quarantine attribute from plugin file to make it work on Catalina (xattr -r -d com.apple.quarantine LongShadow.plugin), if you're downloading it manually and putting it into plug-ins folder
    - or, you can just use AEScripts manager app to install plugins automagically.
    We're not happy about it, but seems like there are no other options for now.
    Can you please clarify where the quarantine attribute is located? 
  • It's set on the plugin file itself. So it depends on where did you copy it to use with AE. Most probably plugin file is in /Applications/Adobe After Effects[version]/Plug-ins folder.
    However, we probably have a better solution that won't make Catalina setting up quarantine attribute - testing it right now!
  • Hi, your plugin is awesome. Can I ask how did you made the gradients and patterns in the shadow in the promo video? 

    Thanks.

    Swenia