MochaImport Plus
  • Hey,
    whenever I wan't to apply an RG Warp Stabilize through MochaImport+, After Effects always freezes and doesn't come back to responding.
  • Hi Josh,

    in particular if your clip is long, this function needs to write a lot of keyframes which might take some time. Don't be irritated if MochaImport+ processes for a few minutes on longer sequences and/or slower machines.

  • Hi Mathias,

    Love your products.
    I was curious about Plus. I usually have no issues making a stabilzed precomp from any point in the timeline with the older version.
    In plus however, when I try to go to the middle of the comp and hit apply it gives me blank data. I'm setting the dialog to start at the beginning of the comp.

    If I move to the start of the comp and repeat the process it works but then it stabilizes from that point in the clip, which is not really ideal.

    Tried this using older version on same project and it worked like a charm.
    Any ideas?

  • Hi Dom,

    the stabilized precomp function of normal and + version are identical, the only thing that is different is the dialog to load the tracking data. When MI+ asks on import which clip you tracked, it expects that your mocha project starts exactly at the inpoint of that layer and places the keyframes accordingly. This is always the case if you use the "send to mocha" button of MI+ to generate your mocha project. If you create the project manually and your mocha project starts at another frame, you can adjust this in the advanced options of the tracking data import dialog. IN general, where the tracking data is placed only depends on your setting in the tracking data import dialog, it should be independent of the position of the current time indicator.

  • Thanks for the quick response.
    Good to know, I'll experiment with it some more.

  • Hi Mathais!

    I got the plugin.. however.. when i hit Track with Mocha.. Mocha opens up.. but is blank.. no footage whatsoever.. I imported footage directly to Mocha, worx, but from MI+, no footage. Please help could not find fix ANYWHERE
  • Are you using the most recent version of MochaImport+? (v4.16)
    Older versions have problems with some kinds of source footage, in particular Red R3D files and MFX files.

    If you have the most recent version and it still does not work, please open a support ticked at and provide us the source footage such that we can reproduce your problem.


  • Firstly thans for the UBER quick reply :D

    Okay, so the source footage is used is the same one u used for the video in Tutsplus on a tutorial you made about a Porche or something.. So its basically the source files for that tut...  Im using 4.1 so im updating and ill let you know ASAP what happens
  • Hello Absolutely love this script!

    especially since you added support for RED footage. I've been having a problem and I was hoping you could help me. When I use the "Track in Mocha" button, which I have set to open Mocha Pro it breaks the link to the license. I usually have to re activate it. After every 3 or 4 time I need to email Mocha and have them reset the license. I'm working on a Mac Pro Tower Early 2008 using Mountain Lion and AE CS6.
  • Hi Scott,

    thank you for this feedback. I didn't know of this issue but its very interesting, since I know that the mocha update check also has issues sometimes when mocha is launched by MochaImport+. It looks like these two are related. I am in contact now with the team from Imagineer Systems to solve the issue.

  • Thank You Mathias

    Talked to Mocha and they said it was an issue between Mountain Lion and Mocha Pro's flex License.

    Thanks for looking into it, I rely on the script so much for dealing with RED files and handling time code correctly it's really indispensable. On top of the flexibility it gives to the tracking data.


  • Hi Scott,
    yes, I got the same info from Mary. I hope they quickly find a solution for it.

    Good to hear that you like MI+ so much :-)
  • MochaImport+ will not work with precomposed layers. This makes my workflow much more difficult, is there a solution for this?
  • Hi Brad,
    what exactly does not work with precomposed layers?

  • Mathias I realized my error, thank you for the great product!
  • Hi Mathias,

    I just tried the trial-Version of MochaImport to see if I need it but there seems to be a bug with interlaced material.
    I have SD25i clips (upper field first). In After Effects the interpretations is correct but Mocha is showing me progressiv field with no chance to change the track settings.
    No idea if this is influencing the tracking result but would be better with the possibility to change the field order.

  • Hi pixxel frame gmbh,

    yes, you are right that the fields information is not set by MochaImport+ currently. It will be integrated in the next version, but this will take some time. However, you can still use the features of MochaImport+ to import the tracking data. Also, as a workaround you should be able to relink the clip (in mocha's clip tab) and choose the correct fields manually.

  • I will try that. Thanks.
    Looking forward to 4.18.
  • Hi, I just downloaded your trial version and keep getting an error message when I click the "Track in Mocha" button, something like "Mocha for AE can only be launched from After Effects". As if Mocha thinks it's being launched from a different application.
    Any idea how to solve this?


  • Hi Adrienne,

    hmm, this is strange. After Effects CS6 has build-in some limitations that disallow other programs to start mocha AE. MochaImport+ has some workaround to avoid this. It is working since about one year without any complaints so far, hence I am not sure what it could be in your case, but I am curious to figure it out.

    Could you please open a support ticket at and give a description of your system (operating system, version number of AE and mocha)? Also, could you tell me what you've set in the settings of MochaImport+ for the version of mocha to use: AE CS6 or "system default program"? (you can open the settings via the cog wheel icon in the MochaImport+ interface)

  • Whenever I click the "Track In Mocha" button, nothing happens.  Sometimes a prompt will come up asking if I want to create a new project or open an existing one, but it never actually opens up Mocha.  I literally just bought the script, so I know I'm using the latest one.   Need help figuring out why it's doing this.
  • Hi Kristopher,

    sorry to hear you have such an issue. I've send you a private email such that we can figure out the details and solve the issue quickly.

  • Mathias, I have sent a private message to your inbox detailing the problem.
  • Hi,

    I'm having problems with Mocha always setting 100% scale on the first frame when it exports to AE.

    Even though in Mocha the scale is 1 on the frame where I initialized the surface, when it exports data to AE, it immediately rescales everything so that scale=100% on the first frame.

    This is a huge problem on shots where something is growing during the shot. I've seen on Mocha forums that other people are also having this issue and so far the only solution that was suggested was to use the clean CornerPin export only - that was 3 years ago :)

    Could you add an option to the MochaImport+ scipt to set a scale reference frame, ie. I want the scale value to be 100% at frame 25 - the whole tracking data would then be rescaled so that it ended up this way.

    Would be cool to have this, since I really don't go through a day without using your script at least once ;)



  • Hi Filip,
    thank you for this idea. Could you explain a bit more detailed what the problem with this is? Is this a problem for corner pin with motion blur or for transform data? For corner pin I would assume that the corner pin effect takes care that your final output has the correct size. For transform data, if you use a null and parent your layer to it, you are still free to scale your layers as you want. 
    If you can explain me how it should work and why its useful, I will think about how to implement it.

  • Actually they both have the same error - but for just transforms as you metioned the workaround is trivial.

    Take a clip where you have your object getting bigger and bigger in the frame. Let's assume you need corner pin (transforms are not enough) and that you will want motion blur on the object.

    You'll get a lyer with corner pin effect and transform data animated.

    Now no matter how you track it in mocha, after you export the data to AE you'll always get 100% scale in the first frame - that's a problem since on the last frame you'll get a scaling of 600% for example. That will make your inset loose quality. It still fits the track but it's just pixelated - the scaling and the corner pin effect work against eachother.

    Strange thing is that if you initialize your surface on the last frame - in mocha you'll see that scale value is 1 on the last frame and it's lower earlier on - the way it should be.

    Unfortunately when you export the data to AE the reference scaling of 100% is set on the first frame :(

    By the way, I'm using Mocha for AE v.2.2.1 with CS5 - maybe it has changed since then?

  • Hi Filip,
    would it solve the problem if MI+ always changes the scale for motion blur corner pin such that the largest scale value is 100% and adjusts the corner pin values accordingly? I think asking for a reference frame would clutter the user interface and irritate many users. Or are there scenarios where you need a particular reference frame?

  • I just checked again with the team from Imagineer Systems:
    In mocha 2.5 and above the scale is set on the last frame you adjusted the surface.  So if you align the surface or adjust it on frame 25 for example, the scale will be 100% from that point and things will scale up and down relative to the tracking data.
  • Good news, time to upgrade :)

    Is it the last frame I adjusted the surface or the first frame I adjusted it?

  • Checked on friend's CS6 - it works as it should.

    Though I still don't understand why AE is getting different scale values than, the ones tracked in Mocha.

    The scale reference frame in AE is the one where you first edited the surface, the scale reference frame for Mocha is the one where you created the spline for the layer.

  • Can I get MochaImport+ to recognize the CC version standard plugin?

  • Hi Kevin, what do you mean with standard plugin?
    In the settings of MochaImport+ (cog wheel icon) you can choose with which version of mocha you want to work. It should list all versions you have installed.
  • Hi Mathias,

    I just bought mochaimport+. Wonderful program. Thanks. Just one small issue, when I click Track in Mocha I get an error message: "License Error: mocha AE CC must only be launched from After Effects."

    Thanks for your advice!


  • Hi Raoul,

    in the settings of MochaImport+ (cog wheel icon) you can choose with which version of mocha it should use.
    Does it make a difference whether you choose "System Default Program" or "Mocha AE CC" there?

    If neither works, please open a support ticked at with infos about the issue itself, what operation system, exact version of AE and which versions of mocha you have installed. The more details I know about the issue, the better I will be able to help.

  • Hi Raoul,

    your issue turned out to be a general problem with AE CC 12.1.
    Its fixed now, see:

  • Hi Mathias

    I suspect that MochaImport+ doesn't support clip with Japanese name? When I click on Track in Mocha, Mocha Pro start up with a popup Relink Clip - Media Unavailable. I tried to choose the sequence images from the popup but it didn't work. However, if the clip is in English it get imported in Mocha just fine. Any info or advice on this issue?


  • Hi Nuntavit,

    thank you for the feedback.

    Can you send me the video clip with the problematic filename? Please open a support ticket to upload the file.
    Then I can check what the problem is and whether I can fix it.

  • Update on Nuntavit's issue: Japanese characters in filenames are no problem. But avoid having dots somewhere in the middle of your filename (use my_name001.jpg instead of my.name001.jpg)
  • Hi Mathias,

    Just bought your script today and I (may have) found a little bug. Using a file with a french accent seems to make the script unable to find the shot when sending to Mocha. I got around it by renaming my original file by getting rid of the accent. So: entrevue_pré did not work, I changed it for and it worked fine. Thought you might want to know.

    Cheers mate!
  • Thanks for letting me know, Nicolas.
    I just fixed the same issue for dots, quotation marks and many other special characters in filenames, but I didn't think about accents. Thanks for letting me know!

  • I just checked the issue with French accents in filenames.
    Actually it is not an issue of MochaImport+, it is one of mocha:
    mocha AE currently doesn't support unicode in filenames, mocha Pro supports it since version 3.2.

    Hence, if you use mocha Pro 3.2 or newer, you can use accents in your filenames, the AE bundled versions don't support it, yet.

  • Hi Mathias...
    still running into issues with unsupported formats.

    Would there be a way to set a proxy in AE and send the proxy into mocha using your plug?

  • Hi Mike,
    this is a great idea for future versions.
    I will put it on my list of feature requests.

  • PS: just noticed that I already have it on the list. Added a +1 :-)
  • Hi Mathias,
    I just bought MochaImport+ and when I click on "Track in Mocha" in Mocha AE CS6, I keep getting a popup saying "Relink Clip-Media Unavailable".  I'm trying to track an .mp4 video file.  Do you have any idea on why that might be?
  • Hi Junior,
    this sounds like the file format is not supported by your version of mocha. Best export your video to an image sequence.
    Also see the section What to Do if Mocha Does Not Support Your Footage here
    (don't be irritated that this page says, mocha supports mp4. This is true for mocha Pro V3, but I think it is not supported in the CS6 version).
  • Mathias, 
    Your suggestion worked like a charm!  Thank you so much.  Keep up the good work!
  • You are welcome :-)
  • Hi Mathias,

      I've installed the new CC 2014 update for After Effects, but when I click on the track in Mocha from MochaImport Plus.  I get the "Mocha AE can only be opened from After Effects" message. Any idea how to fix this.  Tried the old method to fix, but doesn't work.


  • Hi Adam,
    I will check the issue and get back to you.