ft-Effect Instance
  • Hmmm.... funny, for me, it works on Mac but not on PC (both AE CS6). On PC I see only solid gray window, not any of the buttons). Any idea ??? Thanks.
  • I see - no answer from the developer - the plugin is no longer supported - don't buy it for CS6 Win. it doesn't work.
  • I see - no answer from the developer - the plugin is no longer supported - don't buy it for CS6 Win. it doesn't work.
    Sorry about the late answer. I'll try to look into this as soon as possible. 

    cheers, 

    F. 
  • Hi again, I reinstalled my Windows and After Effects and now it works, so I am very sorry for the panic, it works on Win7 CS6. But do not expect, that every single effect will work, for example histogram levels are not instanced...
  • Hi again, I reinstalled my Windows and After Effects and now it works, so I am very sorry for the panic, it works on Win7 CS6. But do not expect, that every single effect will work, for example histogram levels are not instanced...
    good because I couldn't reproduce the bug. 
    Every parameters which cannot be linked via expression, cannot be instanced. Use Level (Individual) instead ;) 

    cheers, 

    F. 
  • Actually as of CS6 even custom data values such as the Levels Histogram can be linked with expressions. You can do it manually in CS5.5+ but scripts require CS6+. It does work in CS6 when using the Link Effects function in my pt_EffectSearch script.
  • Actually as of CS6 even custom data values such as the Levels Histogram can be linked with expressions. You can do it manually in CS5.5+ but scripts require CS6+. It does work in CS6 when using the Link Effects function in my pt_EffectSearch script.
    Thanks Paul, I didn't know about that. I'll look into it. 

    cheers,

    F.
  • Hi. The script doesn't look to work with Element 3D plugin from Videocopilot. When I paste the instance in another comp, it say:
    Can't find the copied effect 'Element' anymore. Please copy it again

    Thanks for your support.
  • Hi. The script doesn't look to work with Element 3D plugin from Videocopilot. When I paste the instance in another comp, it say:
    Can't find the copied effect 'Element' anymore. Please copy it again

    Thanks for your support.
    Are you on CS6  ?
  • In After Effects CC I can't seem to enable/disable the connection.
  • In After Effects CC I can't seem to enable/disable the connection.
    I have to check CC compatibility yet. It's on my Todo, unfortunately I don't have any ETA yet for this. I'll try to that asap. 

    cheers,

    F. 
  • If multiple layers are selected, the script currently only pastes to the 1st selected layer. Would be VERY useful to have the Paste Instance button apply the effect to ALL SELECTED LAYERS.

    Thanks!
  • Does not work with the Perspective-->DROP SHADOW effect. Gives error.
  • If multiple layers are selected, the script currently only pastes to the 1st selected layer. Would be VERY useful to have the Paste Instance button apply the effect to ALL SELECTED LAYERS.

    Thanks!
    Yes I'll look into that

    Does not work with the Perspective-->DROP SHADOW effect. Gives error.
    I'll have to double check this. 

    thanks 

    F. 
  • Just wanted to shout out a huge thank you for this invaluable and powerful, yet very simple tool. It's saved me SO much time + energy. Thank you!! 
  • Hello François, 

    thank you for this great tool! 

    As from today the script doesn't work anymore and gives the following error when pasting a effect onto a other layer: 
    After effects warning: effect named 'Fill' is missing or does  not excist. It may have been renamed, moved, deleted, or the name may have been  mistyped. A property expression referencing  it was disabled. 

    'Color' (line 1) of layer 2 ('BG scene 1') in comp 'MAIN'

    Could you tell me what I'm doing wrong?
  • Thought it was just what I needed.. helps BUT.. as requested before...

    "If multiple layers are selected, the script currently only pastes to the 1st selected layer. Would be VERY useful to have the Paste Instance button apply the effect to ALL SELECTED LAYERS."

    Not useful but essential... go on, pop a loop in your script.


  • I just got this tool and it looked perfect. I shoulda read compatibility. Doesn't work in CC2019.
  • I was hoping this would help me instance an effect which has a few properties that AE wouldn't let me pick-whip. Unfortunately, it only seems to instance the pick-whippable properties. :(
  • Is it working with Aftereffects 2022 or at least 2020?  Thanks
  • Hi,

    I tried it for Hue/Saturation effect but it is not working....