Zorro-The Layer Tagger
  • This is truly awesome. Way more efficient and usable than the layer group method used in others scripts imo.
    I you ever plan to make an update please consider making the UI more compact (Rift is a good example) and the tab title shorter (like "Zorro" instead of "Zorro-The Layer Tagger"), it really is the only downside I think.
  • You can rename the file to make the title shorter.
  • Since upgrade to CC I receive an error with Zorro:

    Unable to execute script at line 334, After Effects error: The section name and key (Label Preference Text Section 5, label text ID 2 # 1) could not be found in the preferences
  • Thanks for reporting this issue with CC. We will fix it and post a new version soon.
  • Thank You, love the tools.... :)

  • Hello,
    the same here, at line 337 !
    Hope you'll update soon ! Thank you !!
  • New version 1.6 posted.  Now works with After Effects CC. To upgrade please refer to this faq: How to upgrade "Name Your Own Price" products
  • Nice update cool !
    Thank you
  • Hi can I ask if the update from 1.55 to 1.6  just adds CC compatibility or does it add other features/ improvments?
    I use CS6 still so don't need CC compatibility but if there were any other improvements I'd definitely upgrade, many thanks
  • Hi can I ask if the update from 1.55 to 1.6  just adds CC compatibility or does it add other features/ improvments?
    I use CS6 still so don't need CC compatibility but if there were any other improvements I'd definitely upgrade, many thanks
    It just adds CC compatibility. You can see the full version history for all products under the VERSION HISTORY tab.
  • Looks like a really excellent script - thanks Lloyd!
  • Great script -- use it every day.

    Question about a problem I've been having -- just upgraded from CC 12.2 to CC 2014 and now when I run Zorro the screen freezes and it takes about 10-30 seconds to process. Before this happened instantly with zero processing time. I've tried trashing prefs and this didn't help. Any idea what's causing this slow down?

    Any help would be appreciated. Thanks.

  • Great script -- use it every day.

    Question about a problem I've been having -- just upgraded from CC 12.2 to CC 2014 and now when I run Zorro the screen freezes and it takes about 10-30 seconds to process. Before this happened instantly with zero processing time. I've tried trashing prefs and this didn't help. Any idea what's causing this slow down? Any help would be appreciated. Thanks.
    Hard to say without knowing more details.  I just tested it in 2014 and it worked fine for me. Can you try it on a new project to see if it's project related? You can also open a support ticket and submit a screencast showing the problem so we can see what you are seeing.
  • Hi Lloyd,

    I'm having a problem running Zorro 1.6 in AE CS 2014 german only. The Message is:  

        The script could not be executed in line 342. After Effecs Error: 
        Could not convert Unicode-Sign.

    Zorro works in AE CC german/english and also in AE CC 2014 english.  
    If you like send me a test version to sort out that bug.  

    Cheers
    Fabian  

    P.S. Version 1.5 produces some kind of preferneces error in CC 2014  
  • Hi Lloyd,

    I'm having a problem running Zorro 1.6 in AE CS 2014 german only. The Message is:  

        The script could not be executed in line 342. After Effecs Error: 
        Could not convert Unicode-Sign.
    This is an After Effects bug.  Please report it to Adobe here: http://adobe.com/go/wish
  • Hi everybody,

    I have the same problem in line 342  :/

    Any solution since the last report to Adobe?

    Here's my configuration:

    After Effects CC (2014.0.4 version 13.0.2.3) / Macbook Pro Retina 15" early 2013 / i7 / 2,4 Ghz / 16Go RAM / SSD 768Go / OSX 10.9.4

    Regards.

    Fabien (from France /Paris)
  • Hi everybody,

    I have the same problem in line 342  :/

    Any solution since the last report to Adobe?

    No please report it to Adobe. The more users they hear from the more likely it is that they will fix it.
  • Hi,

    I have the same problem, Zorro is great but doesn't work :)
    Thank you in advance for help.

    AE CS6
  • Hi,

    I have the same problem, Zorro is great but doesn't work :)
    Thank you in advance for help.

    AE CS6
    If you don't tell us what your exact issue is then we have no chance of being able to help :).  Please provide as many details as possible including screenshots for us to best be able to help you. You can also open a support ticket.
  • With new AE CC 2014.1 release, the "Isolate in Comp (Solo)" doesn't seem to have any effect - unless I'm doing something wrong!
  • With new AE CC 2014.1 release, the "Isolate in Comp (Solo)" doesn't seem to have any effect - unless I'm doing something wrong!
    We have not tested it with that version yet but don't see why it should not work. We can't help you unless you provide more details. Feel free to open a support ticket and provide as many details as possible including screenshots for us to best be able to help you.
  • Hi Lloyd, I don't know if you are aware of this but the script can not be launched with AE CC 2015 french version.
    I don't know wether this is an AE issue or a scripting one.
    image
  • Hi Lloyd
    I'm trying to use Zorro in OS X 10.10.5, AE 13.6.1.6 and get this error "Unable to execute script at line 337. AE errpr: The section name and key(label Preference Text Section 5. Label Text ID #1) could not be found in the preferences.
  • I need to be able to tag and isolate multiple tucked-away layers. 
    Any way to get this to drill down into sub-comps? 
  • I need to be able to tag and isolate multiple tucked-away layers. 
    Any way to get this to drill down into sub-comps? 
    Not in the current version.
  • Hello Lloyd, I am using AE 14.0.0.207 (AE CC 2017 - german version) and have a similar problem like 2014 - the script doesn't work in line 342
    Zorro doesn't work anymore. I like it very much. Best C
    Bildschirmfoto 2016-11-20 um 14.20.18.png
    872 x 176 - 24K
  • Hello Lloyd, I am using AE 14.0.0.207 (AE CC 2017 - german version) and have a similar problem like 2014 - the script doesn't work in line 342
    Zorro doesn't work anymore. I like it very much. Best C
    Hi Loyd,
    I just bought Zorro the Layer Tagger, but I have the very same problem in AE 2017.1 (Version 14.1.0.57) in the German Version.
    I gonna open a support ticket, any other help so far? 
    Best,
    Simon
  • Hey Lloyd, I'm afraid I am having the same problem as a few people here. I've just bought Zorro and when running it I get...

    image

    "Unable to execute script at line 337. After Effects error: The section name and key (Label Preference Text Section 5, Label Text ID 2 # 1) could not be found in the preferences."

    I am running After Effects 2015.3
    version 13.8.1.38

    I absolutely love this plug in (and I think it's the second time I've bought it!) but if it doesn't work then is there a way to get a refund?

    Many thanks in advance for your help!

    Jim
  • Hey Lloyd, I'm afraid I am having the same problem as a few people here. I've just bought Zorro and when running it I get...

    image

    "Unable to execute script at line 337. After Effects error: The section name and key (Label Preference Text Section 5, Label Text ID 2 # 1) could not be found in the preferences."

    I am running After Effects 2015.3
    version 13.8.1.38

    I absolutely love this plug in (and I think it's the second time I've bought it!) but if it doesn't work then is there a way to get a refund?

    Many thanks in advance for your help!

    Jim

    Please try opening the After Effects Labels prefs and then restarting AE.

    image
  • Hello Lloyd, I am using AE 14.0.0.207 (AE CC 2017 - german version) and have a similar problem like 2014 - the script doesn't work in line 342
    Zorro doesn't work anymore. I like it very much. Best C
    Make sure you don't have any non-english characters in your Label color names.  Open the Labels prefs and change any names to english only characters. For example, rename Grün to Green, etc.
  • Thanks a lot, that works!!!!
  • Hi, Lloyd,

    I have problems with the script again.

    This may be related to the fact that it is not compatible with After Effects 2018?

    Until now I used to use the method of removing French unicode characters and everything worked perfectly.

    Recently the error on line 342 has recently returned and I can't fix the problem.

    I don't see where to intervene because I already modified all the names in the labels part to have something resembling the English characters.

    Any idea to fix it?
  • Hi, Lloyd,

    I have problems with the script again.

    This may be related to the fact that it is not compatible with After Effects 2018?

    Until now I used to use the method of removing French unicode characters and everything worked perfectly.

    Recently the error on line 342 has recently returned and I can't fix the problem.

    I don't see where to intervene because I already modified all the names in the labels part to have something resembling the English characters.

    Any idea to fix it?
    Works fine in CC2018. Double check that you do not have any illegal characters in your label names. Also, turn off the Javascript debugger in the AE prefs

    image
  • Hi,
    same issue... maybe because in french "Labels" are called "Libellés"...
    And this is not possible to change...
    snapshot.jpg
    919 x 657 - 133K
  • Hi,
    same issue... maybe because in french "Labels" are called "Libellés"...
    And this is not possible to change...
    Please make sure you restart After Effects after changing the label names
  • Hello. I read in the compatibility tab that ZORRO is only compatible up to AE CC 2015. Can i use it with CC 2018?
  • Hi, thank you for a possibly great script. However, in After Effects 2018, when i do an advanced Timeline (shy) of two layer tags, nothing shows up. If i don't use the advanced search and just add one tag to Timeline (shy) it works. I tried "All Reset" and that gets me back to all layers being visible but when i try the advanced Timeline (shy) with two tags, it still doesn't work.
  • Hello Lloyd, 
    Just download your script to test it on after effect french version and it make me an error at line 342 : impossible to convert unicode characters.

    I've changed the labels names in pref and restart AE but the error is stille here.


    i'm on CC2020

    Any idea of which unicode characters it could be ?

    thanks a lot, your script seems to be great. 
    Don't know why Adobe doesn't make a better solution to organize layers...
  • Hello Lloyd, 
    Just download your script to test it on after effect french version and it make me an error at line 342 : impossible to convert unicode characters.

    I've changed the labels names in pref and restart AE but the error is stille here.


    i'm on CC2020

    Any idea of which unicode characters it could be ?

    thanks a lot, your script seems to be great. 
    Don't know why Adobe doesn't make a better solution to organize layers...
    Please open a support ticket for assistance https://aescripts.com/contact/?direct=1