• Hello and thank you so much for this amazing plug-in! I have a quick question:
    Is it possible to copy and paste the attributes from one Ouroboros shape to another? 

    When I try to do this like I would for other FX, it doesn't make a difference. This would be super helpful (or being able to save Ouroboros presets would be even better!)

    Again, thanks so much for your amazing work.
    We agree, and it the first feature we are working on next!


  • It is the same situation as Kirt critoph.

    1. Ouroboros is installed in the correct folder.
    2. Allow access is turned on. 
    3. AE is restart.
    4. Run Script>Ouroboros
    5, Nothing!!!  There is no reaction!

    How can i fix this? Please help me.

    MY PC specification

    Win 10
    AE CC 2017
    I'm having the same problem mentioned by Kirt Critoph and Ji Yong Park. (Mac, AE CC 2019) 

    When Ouroboros loads, it is a completely blank panel :(
    Screen Shot 2019-09-24 at 16.17.22.png
    906 x 536 - 61K

  • It is the same situation as Kirt critoph.

    1. Ouroboros is installed in the correct folder.
    2. Allow access is turned on. 
    3. AE is restart.
    4. Run Script>Ouroboros
    5, Nothing!!!  There is no reaction!

    How can i fix this? Please help me.

    MY PC specification

    Win 10
    AE CC 2017
    I'm having the same problem mentioned by Kirt Critoph and Ji Yong Park. (Mac, AE CC 2019) 

    When Ouroboros loads, it is a completely blank panel :(
    OK, I found a solution. Hopefully this helps another reader in the future. 

    I read what Sander said about opening up Ouroboros in a new project rather than in an existing project (for a different issue, it seems). 

    Anyway, I tried that, and it worked. 

    Thereafter it was also able to work when I opened up the project I was working on. :)
  • Hello :)

    I need to adapt an old AE project with an old verison of Ouroboros.
    Is there a way to check which version of Ouroboros was used?

    Cheerio!
  • We really really need the copy / paste feature! right now it's a pain using Ouroboros in a project where you make it a part of the style.
  • Just a quick question: I get little gaps between the strokes (see picture). Any solution for this?
    Cheers
  • Just a quick question: I get little gaps between the strokes (see picture). Any solution for this?
    Cheers
    Hi Marc, 

    This is an issue that is created because of anti alias effect from turning vectors into pixels. Unless the shapes are perfectly square there will always be a tiny gap between. 

    There are a couple things you can do so I've recorded a quick tutorial for you to walk through some of them as its going to really depend on your situation what will work best.


    Let me know if you have any other questions,
    Sander
  • We really really need the copy / paste feature! right now it's a pain using Ouroboros in a project where you make it a part of the style.
    Hi Mohsen, We're working on this feature now. would you be interested in testing it? Let me know at [email protected]
  • Hello :)

    I need to adapt an old AE project with an old verison of Ouroboros.
    Is there a way to check which version of Ouroboros was used?

    Cheerio!
    Hi Joris, please open a support ticket so we can help you further. You can get there by going to the gear icon and clicking the "support" button. Cheers, Sander
  • I love this script. I have a little problem that no matter what I do I only see three colors. No matter how many colours I set and try to change delays, speed or other setting I can´t get it to show all my choosen colors.

  • Hi Sander,
    thank you very much for such great support. The Choker combined with a solid & TrackMat the ourobors layer was the perfect solution to close all the gaps. Cheers Marc
  • I love this script. I have a little problem that no matter what I do I only see three colors. No matter how many colours I set and try to change delays, speed or other setting I can´t get it to show all my choosen colors.

    Hi Marc, It's hard to troubleshoot what might be going on here, would you be able to submit a ticket with a screenshot/screen-recording? That way I can check what's going on. (Just go to the gear icon in the script and then click the "support" button)

    Do you have more than 3 stokes on your line? My best guess would be that you have to add more strokes by selecting the ouroboros layer and using the "+" button next to the "ouroboros" button to add more strokes.

    Let me know and chat soon,
    Sander

  • Hi,
    Ouroboros 2 always crashes by hitting this button.
    Working on CC AE 2019 v16.1.2.

    Any idea why?

    Best
    Stefan

    Bildschirmfoto 2020-09-10 um 18.55.27.png
    1276 x 988 - 199K

  • Hi,
    Ouroboros 2 always crashes by hitting this button.
    Working on CC AE 2019 v16.1.2.

    Any idea why?

    Best
    Stefan

    Hi Stefan,

    Not sure why it crashes for you. Would you be able to submit a ticket via the tool?
    Go to the gear icon and press support. Also let us know what sequence of actions you preform to get the error. A screen recording would be best if possible. This way we can see what is happening and help you.

    Thanks!
    Sander
  • ftt ft said:
    How can we make a seamless loop?
    Can you be more specific? What would you like to loop? The more detail you provide the better I can help you.
  • ftt ft said:
    How can we make a seamless loop?
    Can you be more specific? What would you like to loop? The more detail you provide the better I can help you.
    i made a line with dots and random speed. I would like to have same position for my dots, colours and strokes at first and last frame. How can i do that?

  • Hello.
    The plugin doesn't work on the latest After Effects version (17.6.0) on  macOS 11.1 "Big Sur" on Apple M1 Hardware.
    The script is only able to add the ouroboros layer and colours, but every other module does nothing if pressed, therefore it cannot be added to the ouroboros "stack".
    This plugin in is extremely vital to my workflow; thank you very much for your time.
  • The plugin doesn't work … on Apple M1 Hardware.
    For anyone having the same issue, please contact support so we can investigate the issue.



  • For anyone experiencing crashes when opening Ouroboros from the window menu, please follow these instructions:
    1. Open After Effects > Edit > Preferences > General
    2. Click "Reveal Preferences in Explorer" at the bottom
    3. Close After Effects
    4. Open the "Adobe After Effects 17.7 Prefs-indep-general.txt" file in your plain text editor
    5. Search (Cmd/Ctrl-F) for "Pref_SUI_PANEL_USES_LEGACY_SKIN"
    6. Remove the whole block of text (from "[Pref_SUI_PANEL_USES_LEGACY_SKIN]" to the last line of the block)
    7. Save the file
    8. Relaunch After Effects
    9. Open Ouroboros
  • Hi - thanks for this excellent script. Is there a way to loop an animated stroke?  I have an ouroboros set up as a circle, with lines chasing around after each other. It's being made for a loading screen for a web experience, so I need a seamless loop after 4 seconds of animation. It's not a huge deal to just animate manually, but I was wondering if it's possible to set up with your script.

    many thanks

    Matthew
  • Hi - thanks for this excellent script. Is there a way to loop an animated stroke?  I have an ouroboros set up as a circle, with lines chasing around after each other. It's being made for a loading screen for a web experience, so I need a seamless loop after 4 seconds of animation. It's not a huge deal to just animate manually, but I was wondering if it's possible to set up with your script.

    many thanks

    Matthew
    Hi Matthew, 

    There is no looping function and it really depends on the features you use to be able to loop a graphic manually. If you use a random offset for example, strokes will travel at different speeds all ending up in a different place in 4 seconds so its going to be difficult to make those show up in the same spot.

    Sander
  • Hi! Does it works with a path created with the plugin "Connected layers"?
  • Hi! Does it works with a path created with the plugin "Connected layers"?
    Not sure, you'd have to try it out! The download is name your own price so you could try it for free if you want. Please let us know if it worked.
  • Hello :) 
    I wanted to know when the copy paste feature will be available ? I saw you work on it since 2020. 
    I have a ton of ouroboros in many comp which have to be the same, and it's really difficult trying to keep the same each time and do it again and again. 

    As well, does Ouroboros will be soon compatible with the last After effects version, at least 2021 ?

    Thanks for this useful plugin ! 
    Cheers.
  • I wanted to know…useful plugin !  Cheers.
    Hi Cedric, it's still in production, but I sent you a beta version through our ticket system. Ouroboros works in 2021 and 2022.
  • I wanted to know…useful plugin !  Cheers.
    Hi Cedric, it's still in production, but I sent you a beta version through our ticket system. Ouroboros works in 2021 and 2022.
    Hello Remco, 
    Thanks a lot for the reactivity and the opportunity to be a part of this beta version. 
    I installed it, and for now it works like a dream (after effects 17.0 and 22.0, macOs 10.15.7 if useful ). It even create the Ouroboros at the paste on the path, no need to create it before, this is a big improvement.
    Ill keep you informed if I'm experiencing problems, if it can help.
    Thanks again :)