Ray Dynamic Texture
  • Hi Sander - great stuff!
    I am still evaluating the demo. One issue came up you might look into: Applying textures to a already rigged character with DUIK will break the rig atm as effects get the suffix " - RDT" added to them, so the corresponding expressions do not work anymore. Removing the suffix manually gets everything back working, but maybe you can implement a solution into RDT right away?  ;) 
    Thanks, cheers, Lars.
  • Hi Lars, Thank for the heads up on this! I think I know what you mean but would you be able to open a help ticket and send me a quick screencast demonstrating your particular situation? Then I can check with Lloyd if this is something we can fix right now or in the next update.

    Thanks again,

    S.
    Hi Lars, Thank for the heads up on this! I think I know what you mean but would you be able to open a help ticket and send me a quick screencast demonstrating your particular situation? Then I can check with Lloyd if this is something we can fix right now or in the next update.

    Thanks again,

    S.

  • Hi Sander, ticket sent. Let me know, if you need more infos or files. Thanks!  :)  
  • Hi Sander - great stuff!
    I am still evaluating the demo. One issue came up you might look into: Applying textures to a already rigged character with DUIK will break the rig atm as effects get the suffix " - RDT" added to them, so the corresponding expressions do not work anymore. Removing the suffix manually gets everything back working, but maybe you can implement a solution into RDT right away?  ;) 
    Thanks, cheers, Lars.
    Please download v1.0.2 just posted which adds a preference to not rename effects to be compatible with Duik. 

    The issue is because Duik writes expressions using single quotes and there is a bug in After Effects that does not update expressions with single quotes when renaming effects, it only does it when the expression is written with double quotes. See this screencast to see the bug: http://share.aescripts.com/2e3m32103B2h/

    Please contact the Duik developer and ask them to write their expressions using double quotes to fix this issue as it will take Adobe much longer to fix it. 
     
  • Hi Sander - great stuff!
    I am still evaluating the demo. One issue came up you might look into: Applying textures to a already rigged character with DUIK will break the rig atm as effects get the suffix " - RDT" added to them, so the corresponding expressions do not work anymore. Removing the suffix manually gets everything back working, but maybe you can implement a solution into RDT right away?  ;) 
    Thanks, cheers, Lars.
    Please download v1.0.2 just posted which adds a preference to not rename effects to be compatible with Duik. 

    The issue is because Duik writes expressions using single quotes and there is a bug in After Effects that does not update expressions with single quotes when renaming effects, it only does it when the expression is written with double quotes. See this screencast to see the bug: http://share.aescripts.com/2e3m32103B2h/

    Please contact the Duik developer and ask them to write their expressions using double quotes to fix this issue as it will take Adobe much longer to fix it. 
     
    Wow, thanks Lloyd for adding this option - works like a charm!  :)
    Okay, I will ask Duduf to consider changing this in a smaller update or with Duik 16 - crowdfunding starts soon…
    Thanks again, cheers, Lars.
  • Lars Jandel said: 
    Wow, thanks Lloyd for adding this option - works like a charm!  :)
    Okay, I will ask Duduf to consider changing this in a smaller update or with Duik 16 - crowdfunding starts soon…
    Thanks again, cheers, Lars.
    We already contacted them and they said they would add this fix in the next update: https://github.com/Rainbox-dev/Duik/issues/296
  • When I apply Ray Dynamic Texture to a shape layer that has merged shapes using ESL, the texture will paste in the wrong position.  Let me know if you would like a project file to demonstrate the issue.  To replicate, create two separate shape layers, merge them together with ESL, apply RDT to the new merged shape layer.  Look at the position of the applied texture and the merged shape layer.  They aren't the same.  In some cases, the applied texture isn't even visible in the comp window because the position of the texture has such a large value difference.
  • When I apply Ray Dynamic Texture to a shape layer that has merged shapes using ESL, the texture will paste in the wrong position.  Let me know if you would like a project file to demonstrate the issue.  To replicate, create two separate shape layers, merge them together with ESL, apply RDT to the new merged shape layer.  Look at the position of the applied texture and the merged shape layer.  They aren't the same.  In some cases, the applied texture isn't even visible in the comp window because the position of the texture has such a large value difference.

    Please open a support ticket and provide screenshots and the project file so we can beat understand the issue: https://aescripts.com/contact/?direct=1

  • Are layer styles supported as saved effects?  Thanks.

    Kevin
  • I tried to add Adjustment layer with levels and curves but it gives me Errors.
    Is it possible to do this?
  • Hi Chan, 

    As you notice the levels effect will copy over but due to a bug in After Effects custom values in effects are currently not supported. Some examples of custom values are: Histogram in Levels, Curves Graph, Hue Saturation Channel Range and Particular Size over Life. All other values in the effects are supported. We are working to find a workaround for this limitation.

    If you want to apply a custom levels to a texture you can always pre-comp the texture with the effect and it will come in correctly. 

    S.
    Chan Kwon said:
    I tried to add Adjustment layer with levels and curves but it gives me Errors.
    Is it possible to do this?

  • Hi, when I apply RDT to a Shape or solid layer, then choose the texture layer and klick the "invert the selected matte" button, a dialogue pops up, stating "processing ..." which won't finish. It simply stays there.
    AE 2017.2 on MacOS 10.11.6
  • Hi, when I apply RDT to a Shape or solid layer, then choose the texture layer and klick the "invert the selected matte" button, a dialogue pops up, stating "processing ..." which won't finish. It simply stays there.
    AE 2017.2 on MacOS 10.11.6
    Please open a support ticket and include a screencast showing the steps you are taking so we can look into it.
  • Hi Sander, 
    Wonderful plug in! Although I seem to keep running into a major issue. I can't store expressions. 
    I've downloaded the latest version but the result is the same as the version before. Every time I select the layer which I've had expressions and hit save, it come as if it is texture (lavender colour frame) instead of expression (red colour frame). Applying it to my other layer will not get the effect I want. 

    Please tell me how to troubleshoot this or where I can seek help.
    Thanks,
    Terri

  • Hi Sander, 
    Wonderful plug in! Although I seem to keep running into a major issue. I can't store expressions. 
    I've downloaded the latest version but the result is the same as the version before. Every time I select the layer which I've had expressions and hit save, it come as if it is texture (lavender colour frame) instead of expression (red colour frame). Applying it to my other layer will not get the effect I want. 

    Please tell me how to troubleshoot this or where I can seek help.
    Thanks,
    Terri
    Hi Terri,

    It's difficult to tell from your story what might be going wrong. Make sure you select a property of a layer instead of the layer itself when you apply expressions and that the layer inside the texture palette is a Null layer. 

    If your problem still occurs:

    1) Please record a quick screen recording video demonstrating the problem.
    2) Click on the "gear icon" in the script and click "Open Help Ticket" and send us the video there.

    Bonus points if you include an After Effects file but this will allow us to help you better and fix the problem.

    Thanks!
    Sander


  • Hi Sander, 
    Wonderful plug in! Although I seem to keep running into a major issue. I can't store expressions. 
    I've downloaded the latest version but the result is the same as the version before. Every time I select the layer which I've had expressions and hit save, it come as if it is texture (lavender colour frame) instead of expression (red colour frame). Applying it to my other layer will not get the effect I want. 

    Please tell me how to troubleshoot this or where I can seek help.
    Thanks,
    Terri
    Hi Terri,

    It's difficult to tell from your story what might be going wrong. Make sure you select a property of a layer instead of the layer itself when you apply expressions and that the layer inside the texture palette is a Null layer. 

    If your problem still occurs:

    1) Please record a quick screen recording video demonstrating the problem.
    2) Click on the "gear icon" in the script and click "Open Help Ticket" and send us the video there.

    Bonus points if you include an After Effects file but this will allow us to help you better and fix the problem.

    Thanks!
    Sander

    Right! It works now. Thanks a lot for that! : D
    Cheers,
    Terri

  • Hi Sander, 
    Wonderful plug in! Although I seem to keep running into a major issue. I can't store expressions. 
    I've downloaded the latest version but the result is the same as the version before. Every time I select the layer which I've had expressions and hit save, it come as if it is texture (lavender colour frame) instead of expression (red colour frame). Applying it to my other layer will not get the effect I want. 

    Please tell me how to troubleshoot this or where I can seek help.
    Thanks,
    Terri
    Hi Terri,

    It's difficult to tell from your story what might be going wrong. Make sure you select a property of a layer instead of the layer itself when you apply expressions and that the layer inside the texture palette is a Null layer. 

    If your problem still occurs:

    1) Please record a quick screen recording video demonstrating the problem.
    2) Click on the "gear icon" in the script and click "Open Help Ticket" and send us the video there.

    Bonus points if you include an After Effects file but this will allow us to help you better and fix the problem.

    Thanks!
    Sander

    Right! It works now. Thanks a lot for that! : D
    Cheers,
    Terri
    Nice, you got it! Feel free to reach out anytime using the help buttons in the settings menu of the plugin. (gear button)

    S.
  • Are there any plans to update RDT & RDC for CC 2019?
  • Are there any plans to update RDT & RDC for CC 2019?
    Hi Jean-Rene,

    RDT & RDC work in CC2019, if not just click the gear button and open a help ticket to let us know what's wrong.

    If you mean features wise, my question would be, what features would you like to see added to the scripts? These requests are always welcome and help me update the tools.


    Best,
    S.


  • Received a popup message to download new version of Ray Dynamic Texture that's fully compatible with CC 2019 - downladed and installed - says v1.5.5 on the file download, but still showing up as 1.5.4 inside of After Effects (even after shutting and re-starting program).  I'm not getting the 'download new version?' popup any more - just wanted to verify if this was the right file or if anything else needed to be done.   Thanks
  • Received a popup message to download new version of Ray Dynamic Texture that's fully compatible with CC 2019 - downladed and installed - says v1.5.5 on the file download, but still showing up as 1.5.4 inside of After Effects (even after shutting and re-starting program).  I'm not getting the 'download new version?' popup any more - just wanted to verify if this was the right file or if anything else needed to be done.   Thanks
    Please make sure you have replaced the script file and restarted AE, or even better, use our manager app to update it.  If you still need help, please open a support ticket and submit a screenshot so we can see what you are seeing
  • Hey guys. I don't know if this is already possible and I just can't figure it out so forgive me if it is. But I'd like to use 'Set Matte 'S'" mode but for it to use Luminance instead of the Alpha channel. The precomps I texture the most work better with Luminance as Alpha creates artifacts along the edges. This could well be my inexperience as to why I get these artifacts but if there was a way to apply a texture but have it default to using Luminance instead of Alpha I'd definitely prefer using that mode as it's much cleaner to manage in the timeline as mentioned in your tutorials. 

    If there is a way to do this please let me know! It is a small convenience and easily rectified by setting it manually after the texture is applied just something I find myself doing many many times. Thank you! This product is wonderful!
  • Hey guys. I don't know if this is already possible and I just can't figure it out so forgive me if it is. But I'd like to use 'Set Matte 'S'" mode but for it to use Luminance instead of the Alpha channel. The precomps I texture the most work better with Luminance as Alpha creates artifacts along the edges. This could well be my inexperience as to why I get these artifacts but if there was a way to apply a texture but have it default to using Luminance instead of Alpha I'd definitely prefer using that mode as it's much cleaner to manage in the timeline as mentioned in your tutorials. 

    If there is a way to do this please let me know! It is a small convenience and easily rectified by setting it manually after the texture is applied just something I find myself doing many many times. Thank you! This product is wonderful!
    Hi Will, 

    The Set Matte function has these options. After you texture your layer with the set matte  function go to the effects window and try changing the "Use For Matte" property to Luminance. See this image: https://imgur.com/a/7VwKe1f

    Curious to know if you worked!

    (Sometimes when I get weird edges around my mattes I use the "Simple Choker" effect. Might help... not sure)

    Sander
  • Thanks for the quick reply Sander! 

    I figured out how to change the luminance manually like you said. I was curious if there was an option to automatically set the matte method when you applied the texture rather than manually afterwards. It's a very small thing, but perhaps it can be an checkbox option in the settings menu in a later update. 


  • Hi,

    I really love your products that's why I'm sad to have an issue with the After Effect 2020.

    When I want to open the panel (after enabling the "scripts to write files and accessing network" which is in Scripting and Expression now)
    I get this : "Unable to execute script at line 8. Function c.setDate is undefined"

    What can I do ?

    Cheers

    Greg
  • Hi,

    I really love your products that's why I'm sad to have an issue with the After Effect 2020.

    When I want to open the panel (after enabling the "scripts to write files and accessing network" which is in Scripting and Expression now)
    I get this : "Unable to execute script at line 8. Function c.setDate is undefined"

    What can I do ?

    Cheers

    Greg
    Please make sure you are using the latest version of RDT. If you still need assistance open a support ticket
  • Hey, I just bought RDT and it seems "Invert the selected matte" is broken. I assume the texture layer is the correct one to be selected to use this feature, but I tried selecting the other layers as well, in all cases the button does not invert the matte mode. Cheers

    Windows 10 Pro Build 18362
    AE 17.0.1 (Build 52)
    RDT v1.5.6
  • Hey, I just bought RDT and it seems "Invert the selected matte" is broken. I assume the texture layer is the correct one to be selected to use this feature, but I tried selecting the other layers as well, in all cases the button does not invert the matte mode. Cheers

    Windows 10 Pro Build 18362
    AE 17.0.1 (Build 52)
    RDT v1.5.6
    Hi Nathan,

    Would you be able to send me a screen recording of the issue you are running into as a ticket? Then I'll be albe to help you figure out what is going on. To send a ticket, click on the little "gear" icon in your script and hit the "Open Help Ticket" button.

    The black and white button with A, L or sometimes S in it, is used to set the matte you want to texture with. You won't be able to use it to switch mattes on exiting layers. I believe this is what you're describing but again, a screen recording will make this more clear. You might actually came up with a cool new feature as I think it would be handy to be able to use the button to switch mattes of existing layers as well.

    Let me know,
    Sander
  • Hi, I'm having the following issues using your trial version.

    When you apply the texture, it is said that your video (ttps://www.youtube.com/watch?time_continue=114&v=OFh_M4mi360&feature=emb_logo)  around 5:11 changes the mode  multuply and the opacity becomes 50.

    But when I do the same, the drawing mode remains normal. The opacity remains at 100%.
    windows10

    The latest version of aftereffect2020.
  • Hi,

    I have an issue with visibility of a swatch. It's the first swatch in row that does not stay visible.
    I imported some other textures and they stay visible all the time.
    After effects 2019 MAC OS Catalina 10.15.7


  • Hi,

    I have an issue with visibility of a swatch. It's the first swatch in row that does not stay visible.
    I imported some other textures and they stay visible all the time.
    After effects 2019 MAC OS Catalina 10.15.7


    Hi Nils,

    I'm not sure what is causing this to happen. Would you be able to send in a ticket? Click the Gear Icon and then click "Open Help Ticket". Just copy and paste your message and video in there so it goes to the support team and they can help you out from there.

    Cheers,
    Sander
  • I've been using Ray Dynamic Texture today for layer styles and other effects instead of.. textures. It's incredibly useful in compositions with repetitive UI, specially in combination with Dynamic Color. We work in marketing for games, there are loads of buttons and being able to iterate like this is just fantastic. You should really advertise that option more, I had no idea there was something that could make these dynamic! I'm in love with both of your plugins, it's hard to put a number on how many hours of work you've saved us. 

    I would really love the ability for a different view with full name labels so I can find what I'm looking for quickly when I have a lot added (for both plugins) but I'm honestly being picky, the plugins are fantastic as is.

    Thanks you so much and congratulations for doing such a clean, intuitive and neat work!!
  • Hi,
    Love it and works perfectly until AE 2021 .. I got 10 expressions issues when I used it . Is it compatible with AE 2021 ?
    Thanks

    Windows 10
    AE 18.1.0
    RDT 1.5.7
  • Hi,
    Love it and works perfectly until AE 2021 .. I got 10 expressions issues when I used it . Is it compatible with AE 2021 ?
    Thanks

    Windows 10
    AE 18.1.0
    RDT 1.5.7
    Hi Valerie,

    Would you be able to submit a ticket and attach some screenshots? That way I can check what expression are not working. Just go to the little gear icon in the script and click on "Open Help Ticket".

    Thanks,
    Sander

  • Hello. So I noticed in the YT video when you add a texture to a solid, you get the original solid, the texture image and a copy of the solid on top. When I follow the same steps  the comp (RDT...) shows up under the original solid as a guide layer. Is there a setting to not have that extra layer show up?

    Thanks 
  • Hello. So I noticed in the YT video when you add a texture to a solid, you get the original solid, the texture image and a copy of the solid on top. When I follow the same steps  the comp (RDT...) shows up under the original solid as a guide layer. Is there a setting to not have that extra layer show up?

    Thanks 
    Hi Nome Nomie,

    The comp (RDT...) is there to make sure the composition you work in has a copy of the texture palette. This way it won't ever get deleted by accident. To hide that layer at the bottom you can use the hidden layer function: https://qph.fs.quoracdn.net/main-qimg-cdc629363bd0abc907d6fc301da2cdc3

    1. When you for example consolidate the project, After Effects will only keep the comps that are selected in the project panel and delete everything else it thinks you don't need. This has resulted in AE deleting texture and color palettes because they were not part of the selection. This can lead to missing textures. By including the texture palette in the comp, AE will not delete the texture comps when they are not selected, because they are part of a selected comp.

    2. When you are in the texture comp to adjust the textures. You can use the mini flowchart (shortcut = TAB) to go back to the comps that use that texture palette. This way it also shows you what comps use what texture palette. 

    There is not way to remove that layer because its a much bigger problem when the textures go missing, it would be really hard to rebuilt that unless you have a backup of your project. 

    Sander
  • This has to be the single best tool I've ever purchased.

    I just worked on a project with 15x ~1 animations in a paper cut out style which they decided to do digitally rather than real paper and stop motion (good call!)

    Ray Dynamic Texture made texturing every asset an absolute breeze. Bloody brilliant!
  • Hi Sander 

    I love this Plgin you created I am just getting started but I wanted to know something , The texture default pack that you start with where is best to keep those sorted in Adobe after effcets Libraries or do they need to be within every new project file you wish to use them in? or id dones matter where you have them :/ hope this not stupid question.

    Many thanks Mish
  • Mish Zac said:
    Hi Sander 

    I love this Plgin you created I am just getting started but I wanted to know something , The texture default pack that you start with where is best to keep those sorted in Adobe after effcets Libraries or do they need to be within every new project file you wish to use them in? or id dones matter where you have them :/ hope this not stupid question.

    Many thanks Mish
    Hi Mish, 

    You can store them anywhere you want. I keep a folder on my hard-drive called Global Assets. In there I save the AE projects that have the texture libraries in them that I use often. If I need one, I simply drag them into my project. If you work in a studio and have multiple computers hooked up to one server, you can place the the global assets folder there so you never have files go missing as long as you have access to that server. You could also use dropbox for example.

    Hope that helps,
    Sander