Mask Prompter
  • Since it seems that there is still no solution to the problem where multiple plugins of yours together result in a crash and where only one of them works (depending on which one has been installed last), here is a temporary solution:

    Since it seems that the core files of the plugins are located in "Program Files\Blace Plugins", the fix is that instead the installer creates another folder for each plugin in that program files location where within these core files for each individual plugin exist. Then when the plugin is called in after effects, it looks for these core files in these specific folders, resolving the crashes.

    Example folder structure:
    Blace Plugins \ MaskPrompter
    Blace Plugins \ DepthScanner

    If Mask Prompter is called, it looks in "BlacePlugins\MaskPrompter". If DepthScanner, "BlacePlugins\Depthscanner".

    This isn't the best solution as these core files are heavy in size, but it would resolve the very common crash problem (as it seems) for the time being and would satisfy your customers that have paid you.
  • unusable in AE2024, keeps crashing...

    I am using EXR's 32 bit, in ACEScg colour space.. that got something to do with it??

  • gami vopa said:
    Since it seems that there is still no solution to the problem where multiple plugins of yours together result in a crash and where only one of them works (depending on which one has been installed last), here is a temporary solution:

    Since it seems that the core files of the plugins are located in "Program Files\Blace Plugins", the fix is that instead the installer creates another folder for each plugin in that program files location where within these core files for each individual plugin exist. Then when the plugin is called in after effects, it looks for these core files in these specific folders, resolving the crashes.

    Example folder structure:
    Blace Plugins \ MaskPrompter
    Blace Plugins \ DepthScanner

    If Mask Prompter is called, it looks in "BlacePlugins\MaskPrompter". If DepthScanner, "BlacePlugins\Depthscanner".

    This isn't the best solution as these core files are heavy in size, but it would resolve the very common crash problem (as it seems) for the time being and would satisfy your customers that have paid you.
    So can we apply this fix ourselves? We should make those sub folders in the program files folder?
  • We interrupt your regular stream of support requests to bring this important message:
    This plugin is an absolute life-saver! 
    That is all, as you were.
  • I have been trying for weeks to have this application work. The website www.blaceplugins.com doesn't seem to be online and everytime I try and download this application I just get nothing. What gives? 

  • I have been trying for weeks to have this application work. The website www.blaceplugins.com doesn't seem to be online and everytime I try and download this application I just get nothing. What gives? 

    Hey,
    please open a support ticket. This is probably due to some firewall settings. 
  • gami vopa said:
    Since it seems that there is still no solution to the problem where multiple plugins of yours together result in a crash and where only one of them works (depending on which one has been installed last), here is a temporary solution:

    Since it seems that the core files of the plugins are located in "Program Files\Blace Plugins", the fix is that instead the installer creates another folder for each plugin in that program files location where within these core files for each individual plugin exist. Then when the plugin is called in after effects, it looks for these core files in these specific folders, resolving the crashes.

    Example folder structure:
    Blace Plugins \ MaskPrompter
    Blace Plugins \ DepthScanner

    If Mask Prompter is called, it looks in "BlacePlugins\MaskPrompter". If DepthScanner, "BlacePlugins\Depthscanner".

    This isn't the best solution as these core files are heavy in size, but it would resolve the very common crash problem (as it seems) for the time being and would satisfy your customers that have paid you.
    So can we apply this fix ourselves? We should make those sub folders in the program files folder?
    No, this was just a (well thought) proposal, but won't work. We'll have a permanent solution soon.
  • I would buy this plugin in a heartbeat if I could get to work...
  • I would buy this plugin in a heartbeat if I could get to work...
    Please open a bug report: https://aescripts.com/contact/?product_id=2133
  • The installation Failed for MaskPrompter v.1.11.13 MacOS version

    Please, I need help to install this plugin

    It's having error - The installation failed message.

    Just purchased yesterday.

    I've already open a ticket. Please fix the error.  
  • Hey, I just purchased the plugin, but the installation proces gets stuck. Already rebooted my computer a few times, but it gets stuck exactly on the same place in the loading bar every time. Help would be appreciated.

    cheers,
    Rogier 
  • Hey, I just purchased the plugin, but the installation proces gets stuck. Already rebooted my computer a few times, but it gets stuck exactly on the same place in the loading bar every time. Help would be appreciated.

    cheers,
    Rogier 
    Hey, please read: https://docs.blaceplugins.com/installation.html#running-package-scripts
  • After Effects - 23.6.2 Build 5, Crashes when choosing the Mask 1, Tried pretty much everything else with no success. Uninstalled and reinstalled the plugin. I should point out that I'm very much up to date with all things CUDA, as well as the Toolkit,... ComdyUI/Stable Diffusion User here... 
    I only bring that up because something leads me to believe there may be some Stable Diffusion Clip Vision, or Segmentation under the hood of the plugin. 
    HPZ820 Dual XEON, 128GB RAM nVidia RTX3090 with 24GB of RAM. 
    Any suggestion would be welcomed.  
  • After Effects - 23.6.2 Build 5, Crashes when choosing the Mask 1, Tried pretty much everything else with no success. Uninstalled and reinstalled the plugin. I should point out that I'm very much up to date with all things CUDA, as well as the Toolkit,... ComdyUI/Stable Diffusion User here... 
    I only bring that up because something leads me to believe there may be some Stable Diffusion Clip Vision, or Segmentation under the hood of the plugin. 
    HPZ820 Dual XEON, 128GB RAM nVidia RTX3090 with 24GB of RAM. 
    Any suggestion would be welcomed.  
    Hey Leonard, please reach out via a bug ticket here: https://aescripts.com/contact/?product_id=2133
  • I tried this plugin before purchase and it crashes on vanilla after effects v.24.1.0 and latest Nvidia drivers.  If this is reliable enough I'll deff consider buying it.
  • I tried this plugin before purchase and it crashes on vanilla after effects v.24.1.0 and latest Nvidia drivers.  If this is reliable enough I'll deff consider buying it.
    Hey Alex, please reach out via a bug ticket here: https://aescripts.com/contact/?product_id=2133
  • I can't install all the products of blace plugin with this update. Please check
  • I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
  • I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.
  • I'm having this same issue with all the updates to the Blace Plugins.
    I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.

  • I'm having this same issue with all the updates to the Blace Plugins.
    I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.

    Hey, are you able to download and install from the product site directly?
  • I'm having this same issue with all the updates to the Blace Plugins.
    I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.

    Hey, are you able to download and install from the product site directly?
    I am, but unfortunately, when I do that, the aescripts manager shows it as not installed, at all. So, it's constantly showing up as a plugin that needs to be installed/updated. The Blace plugins are the only ones showing this. Is this something that is planned on being addressed? I have five of your plugins, and without this fix, I will constantly need to manually download and install updates each time any of the five plugins get updated.
  • I'm having this same issue with all the updates to the Blace Plugins.
    I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.

    Hey, are you able to download and install from the product site directly?
    I am, but unfortunately, when I do that, the aescripts manager shows it as not installed, at all. So, it's constantly showing up as a plugin that needs to be installed/updated. The Blace plugins are the only ones showing this. Is this something that is planned on being addressed? I have five of your plugins, and without this fix, I will constantly need to manually download and install updates each time any of the five plugins get updated.
    Update - I was able to use aescripts manager to successfully update all the plugins. Thank you!
  • I'm having this same issue with all the updates to the Blace Plugins.
    I can't install all the products of blace plugin with this update. Please check
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.

    Hey, are you able to download and install from the product site directly?
    I am, but unfortunately, when I do that, the aescripts manager shows it as not installed, at all. So, it's constantly showing up as a plugin that needs to be installed/updated. The Blace plugins are the only ones showing this. Is this something that is planned on being addressed? I have five of your plugins, and without this fix, I will constantly need to manually download and install updates each time any of the five plugins get updated.
    Update - I was able to use aescripts manager to successfully update all the plugins. Thank you!
    Thanks for the feedback, we fixed the links :)
  • Hi
    Im trying to install the Mask Prompter trial, but as soon I play with it.. I have this error on Mac, AE 2024, Ventura OS - Mac Mini M2.
    What should I do?
    Thanks
    Tom

    Screenshot 2024-03-01 at 11.16.09 AM.png
    886 x 256 - 40K
  • Tomas E. said:
    Hi
    Im trying to install the Mask Prompter trial, but as soon I play with it.. I have this error on Mac, AE 2024, Ventura OS - Mac Mini M2.
    What should I do?
    Thanks
    Tom

    I think you already opened a ticket, didn't you? This issue should be solved by deleting 1) /Users/<username>/Library/blacetemp/cache

    2) /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore/MaskPrompter.plugin and running the installer again.

  • I'm having this same issue with all the updates to the Blace Plugins.
    I can't install all the products of blace plugin with this update. Please check 
    Hey, what error do you get?
    I apologize for not opening a ticket as this is an urgent issue. When I try to install all blace's plugins through the manager, it fails to install because there is no installer.

    Hey, are you able to download and install from the product site directly?
    Candy Crush said: I am, but unfortunately, when I do that, the aescripts manager shows it as not installed, at all. So, it's constantly showing up as a plugin that needs to be installed/updated. The Blace plugins are the only ones showing this. Is this something that is planned on being addressed? I have five of your plugins, and without this fix, I will constantly need to manually download and install updates each time any of the five plugins get updated.  
    Thank you! 
  • Reading comments ...  fascinating. Installer is obviously a piece of s...t, process doesn't work, and ... no fix . 
  • Reading comments ...  fascinating. Installer is obviously a piece of s...t, process doesn't work, and ... no fix . 
    Hey, unfortunately we have a bug on some MacOS systems, where the model file cannot be loaded. We are working on this with high priority. Please follow the products updates.